"MarkUp" scene not viewable in SketchUp 2022

I work in residential construction and use SketchUp for IPad to draw out basic dimensions of a job site then use the MarkUp tool to write notes. I export this file to my computer and use that as a base for the design process.

However, When I go to view the Markup Scene it doesn’t appear on my screen. When I switch from the Markup scene to the default scene my notes briefly appear before fading out.

Is this a bug or is there a setting I can adjust to make this stop?

Any help would be appreciated.

AFAIK the markup interface is not (yet?) supported in the desktop version.

1 Like

Okay so I checked the original file on my iPad and it was also having the same issue (Markup not showing) So I tried a different design and it seemed to work just fine.

IDK if this was just a bug or if it is repeatable. I am unsure what I did different between these two examples.

That’s good. I tried, and the markup scene does seem to behave on desktop.

If the scene you are starting from has a style setup that has overlay images turned off, they will be turned off in desktop app when you open them.

I think SU for iPad should force that particular tick box to become active for any style and update that style, if we create a markup from it.

Hi @ajj3950 thanks so much for the report.

In both cases, did you begin each project by starting on iPad, or did you begin one of the projects by starting on Desktop and then going to iPad?

@JQL I checked the behavior of Markup Mode, and after creating a file in Desktop with the Style properties set to have watermarks turned off by default, I was able to then go to SU for iPad and create a markup scene. SU for iPad is already turning the Display Watermark checkbox on in cases when it’s not already.

I tested using SketchUp for Desktop on my Mac. Are you seeing something different when going between Windows desktop and iPad?

I have reported this in the past Mike though I haven’t tried again. I am also able to create the scene in iPad under those circumstances. What I couldn’t do is view it in desktop afterwards, without turning on the watermarks on styles.

@MikeTadros I began both of these projects on iPad then exported to SketchUp 2022 for Windows. Exported is a bad word though. I uploaded the file to Drop Box then opened on my desktop.

@JQL yeah, I’m starting to wonder if the bug is somehow more to do with SketchUp Desktop for Windows. I’ve tried a bunch of combinations of workflows with different style states prior to and after toggling off watermark visibility when working across SketchUp Desktop for macOS and iPad and am unable to reproduce the issue. We’ll keep digging on the Windows side to see if we can figure out what’s going on.

This is actually happening reliably in my models. I make a markup scene, come back and it only shows briefly for a moment as you switch scenes.

It has happened on four models, two of which had multiple markup scenes, though never more than one scene per model was acting up. I have been just redrawing, but saved this file for you. None of these models has been anywhere other than my iPad, however, all have elements that have been copied out of other models that may have been to 22 pro and back.

WM sauna Breakouts.skp (1.7 MB)

@JQL @Danimaupin @ajj3950
I’ve spent some time today diggin back into this issue (in the Mac Desktop app, where I can see the list of in-model styles). I think I’ve got a grip on the issue you’re seeing, and the clues you’ve offered, but no matter what combination of steps I try, I am still unable to reproduce an end state that replicates those issues – and that’s an essential pre-requisite for being able to fix whatever’s broken…

Dani, thank you for sharing that file, It’s super helpful, as I think it includes all of the conditions that you, AJ, and João have reported. Here’s what I’m seeing in the file you shared:

There are two scenes (note the date & time stamp in each scene):

  1. Markup - 8/17/22, 11:36 AM
  2. Markup - 8/17/22, 11:43 AM

And five styles:

  1. Architectural Design Style1 (Display Watermark property is checked ON)
  2. Markup - 8/17/22, 11:34 AM (Display Watermark property is checked ON)
  3. Markup - 8/17/22, 11:36 AM (Display Watermark property is checked ON) – This is the active style for the scene titled “Markup - 8/17/22, 11:36 AM” (as it should be)
  4. Markup - 8/17/22, 11:42 AM (Display Watermark property is checked ON)
  5. Markup - 8/17/22, 11:43 AM (Display Watermark property is checked OFF) – This is the active style for the scene titled “Markup - 8/17/22, 11:43 AM” (as it should be)


  1. Why is the Display Watermark property unchecked in the Style titled “Markup - 8/17/22, 11:43 AM”? (same question to each of you, with regard to times when you see this happening in your respective models) Is that something that you did while working in Desktop? If not, then that’s a) bizarre, and b) not something we’ve been able to reproduce – so any clues from anyone as to the steps you’re taking to end up in that state would be very helpful.
  2. Why are there 4 markup styles and only 2 scenes? Were there 4 markup scenes, 2 of which you deleted? I’m wondering if deleting markup scenes may be contributing to what’s going on there?
  3. The styles have time stamps that are very close together… I’m wondering if maybe there’s another clue there? Perhaps working to create/modify/delete markup scenes very quickly, lends to the issue?

For the symptom where you go from one scene to another scene, and briefly see the markup layer as it fades out, that’s normal behavior.

It happens because when you go to another scene, some of the settings switch immediately, before the animation starts. In your case you had markup for that scene, but in styles you had turned off watermarks. As you go to the other scene, that does have watermarks enabled, you briefly see the watermark from the current scene, because the destination scene has already enabled watermarks.

So, because it’s only ever been on iPad, is there a setting for scenes and markups?

On desktop there is a style option to control whether watermarks are shown.


I don’t see the same option on iPad, it seems to be controlled by the markup feature.

I could get into the same situation as in your model:

  1. Make a couple of markup scenes.
  2. Test going between them, it works ok.
  3. Orbit a tiny amount, which will hide the markup.
  4. Save.

Now when you reopen the model the scene that you were on no longer shows the markup.

Okay. This particular model has never been to any desktop version as it is just for my notes and I only send them to desktop to go into LayOut. I have no idea how the styles got changed.

Nope. This model has never been to desktop. It has copies of groups from another model that may have been, but I only ever send models to desktop in order to transfer them into LayOut, and in this one’s case, I’m sure I downloaded a copy onto my desktop files in order to move it, so even then, the file never came back to iPad. I’m mostly positive this is from an earlier model than the one that traveled.

Almost certainly! I am a horrible abuser of markup! I actually use it most as a sketch layer underneath something I want to model, then model over the top of that “sketch” before rotating off to finish the dimensions. The only reason these two didn’t get deleted is because they have actual info that I wanted later.

I do tend to do this, yes. For me, It’s sort of like flipping a sheet of paper to take new notes. One of the Models (not available anymore) did have this issue with about 24 hours between the markup scenes though… I remember because the client texted and asked if the new drawings were done and I said it had only been 24 hours, and my assistant corrected me and said 23. :laughing: he’s so helpful.

I didn’t do it! It wasn’t me! It’s not my fault!

That might be where the issue is. I know I didn’t change markup style property on any particular style. The issue pops up where the markup disappears and only after will I turn the property on, in order to see the markup.

It seems to me it’s sketchup for iPad that is tinkering with that.

This is related to Dani’s scene right? I may check but I don’t remember seeing more styles than markups.

I still think it’s very cumbersome to have markup related to styles. I understand this is a clever use of the watermark feature, but the growing styles list is too dirty.

If you are going to keep the styles route, maybe you could have a feature where the same style tores all the watermarks/markups for all the scenes, yet it allows for different scenes to use different watermarks. So, same style, different watermarks per scene, instead of a new style copy for each watermark.

Better than that, would be to have a specific markup manager with dedicated markup features and a specific entry on scene settings

That is something I’m doing. Sometimes it’s quickly, sometimes is in another day, but I do like to work on top of previous markups.

@colin wins (yet another) trophy! :trophy:
With the steps above I am able to reliably repro the issue.
Thanks all for the notes, feedback, file sharing, and sleuthing!
I will get this filed.

(The good news, if there is any, is that the markups aren’t actually being deleted and that by taking your model over to Desktop you can flip the watermark back on and resave the scene. Also a good idea, while we work on fixing this issue, to have a scene in the model that you can activate before saving and closing the file)

It’s been there a while…


OK… we figured out what’s going on here. And we think that today’s launch of SketchUp for iPad v6.1 includes a fix that should prevent Markups from disappearing.

Probably notable that the fix applies to SketchUp for iPad – meaning that you might still find in some cases that your markups aren’t visible in markup scenes when viewing those scenes in SketchUp for Web or SketchUp for Desktop.

If that happens, the short version of the ‘fix’ (without getting into all the nitty gritty about what’s going on under the hood) is to:

  1. Open your model in SketchUp for iPad.
  2. Activate the markup scene that contains the misbehaving Markup.
  3. Save & close your SketchUp model.
  4. Reopen it in Desktop or Web.