Make Unique option disappears

After some time of working on a fairly large model in SU2021, the Make Unique option in the context menu stays greyed out, i.e. no longer available. As a workaround I have to ‘Save’ & close down and restart the model.

Make sure that you are using the latest maintenance release of SketchUp 2021 (21.1.332). The grayed-out context menu issue ought to be fixed in that

Yes, I had updated to the latest release some time ago already, but the issue persists.

The current version is 21.1.332. Is that what you are using?

Is it only Make Unique that is grayed out?

[menu] Help > Check for updates

Thanks Dave - yes that is the release version I am using. It happened on another context menu option a few days ago too (can’t remember which one now), and I’ve tried reducing the number of open extensions to a minimum to see if that affects anything. It might do, according to the release notes anyway.

I haven’t seen the grayed out Context menu items since the last update despite have a fairly large number of extensions loading.

Next time you see the grayed out Make Unique, do two things. Look at Entity Info to make sure there’s really more than one instance of the component in the model. If there is, make a note of what other Context menu items are grayed out. If it’s the problem that was solved with the update, it won’t just be Make Unique.

1 Like