Locked out of Sketchup, web sign-in doesn't handoff to app, endless "Launch Browser Again"

I used SketchUp earlier today with no problems. Just now I try to launch it again and I’m required to sign-in via a web browser. I sign in, web browser says “close tab and continue”, but the app just says “Launch Browser Again”. I’m totally locked out of SketchUp.

I cannot express how frustrating this is, especially under stress of a work deadline. The fundamental promise of subscription-based or login-based software is that it is available to paid users 100% of the time. I miss my classic license.

1 Like

Same issue here on a fresh install with a Mac. I sign in on the web but the app doesn’t do anything.

I checked with the team who will know about these things, and there was a brief issue a short while ago. Can you please try now?

I’ve had a few of these over the last few days, this is what I’ve done to help.
Hopefully it solves it for you too

Quit SketchUp and Layout completely and delete the WebCache folder from inside here:

~/Library/Application Support/SketchUp 2022/

You have to go to your finder on Mac. Go to the “Go” tab, past that above link and delete the Web Cache folder.

Restart your Mac and then try signing into SketchUp again

1 Like

That may sometimes be what helps. In this case though it was unusual to have two reports within a few minutes of an issue happening at our end.

It turns out that while I was typing the original post, I could see SketchUp, in the background, “register” and switch to the modeling environment. So it didn’t work, and then magically it did.


I’m stuck in this same sign in loop … I’ve cleared the browser caches, restarted the computer, and I’m still asked to sign in. I can’t log myself out of the app under the help menu, because none of the app functions are available. I can log into my Trimble account on Safari, on Chrome, and I’ve cleared those browser caches to try to get things up and running with SketchUP, but SU 2022 doesn’t let me sign in. I’ve just upgraded to a SketchUp Pro subscription, and I was using an earlier version of SU. SketchUp prompted me to download the newest version of SU 2022, and I’ve been stuck in this loop ever since.

Please send your magic to LandSight.

I am having the same issue since updating the Mac OS, and have tried all of the same fixes.

“Launch Browser Again” goes nowhere. Have deleted web caches and .dat files and tried different default browsers. Nothing…

Thanks - this worked