Load Errors upon Startup

I am an experienced user and tester of SketchUp Pro and have been for some time. I am having an issue presently where I am getting a LOAD ERROR upon starting up the software. There is a message that says “Error: SketchUp:1:in `eval’”. I have tried turning off all of my plugins but that does not work. Do you think I should remove everything from my plugins folder and reload and restart the software to see if and which plugin is causing the issue? Does anyone else have this issue and if so what plugin is doing it to them? Maybe I have the same one.

Do we think it would be a good idea for the sketch plugin database to be reviewed to make sure that all scripts have been updated to the new Ruby and older scripts be removed so that people are not using them and having issues?

Thanks for the help everyone.

use Finder to rename ‘Plugins’ to ‘notPlugins’ and see if it helps…

SU will make a new one for it’s extensions, so you can then move ‘yours’ back sequentially to find the issue…

you really need to copy paste errors into a code block for any one to read them,


A few plugins put their files in the shared /Library instead of your personal ~/Library. Be sure to also check there for offenders.

If you are getting load errors on startup, the errors should tell you which extensions are having problems. You shouldn’t have to disable the whole lot.

Which version of SketchUp are you running? Your profile is incomplete. When you installed SketchUp, did you then install fresh copies of all the extensions or did you copy them from an older installation?

24 AM

I am having this issue also. I chased down all of my paid extensions to make sure I did not have one in Trial Mode and that did not resolve. Is there a way to see what is being loaded and the potential problem?

Do either of you have the plugin Follow And Rotate?


I was getting the same same error message, and uninstalled Follow & Rotate (there were 2 versions).

Now there is no error. Thanks @Box!

1 Like

Is there a problem with these plugins? I do have them in the library.

I am right now in the process of clearing everything out and adding in a few at a time to see if I can narrow down which one is the culprit.

I wonder why these are not working…I did notice that these files are .rbs files as opposed to .rb files. Do we think that that is the issue?

I can’t recall where I saw it, but I think that this error can be provoked by malformed Ruby code as SketchUp attempts to load an encrypted extension. Alas, because this particular extension is encrypted, only the author can (legally) look to see whether the code is clean.

The problem isn’t that the file is a RBS file.

Well, in a sense it is: when the error occurs while loading a RBS file, SketchUp posts this unhelpful message instead of a clearer report of exactly what was wrong with the Ruby code encrypted in the RBS. It doesn’t even tell you what it was trying to load at the time! I suppose that might have been done intentionally to protect the intellectual property rights asserted by encryption?

1 Like

Is there something we can do to t he.rbs file to maybe correct this issue? I am just thinking about learning what to do and how to use Ruby and maybe coding some of my own things once I get a book and do a read-thru.

If you code yourself are there any books you can recommend? Send me names and authors, please.

Thanks so much.

contact the author, after looking for an already updated version…

.rbs is an encrypted file to stop you or I ‘fixing’ it…

look in the Ruby forum for links to resources…


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.