Load error reinstalling Greyscale Plugin SU2016

2016

#1

I just updated to Sketchup 2016 today and am trying to get my extensions back.There is one that I use from Smustard by JF Tools called Greyscale. It worked fine in my 2015, but I installed the Zip with the Simple Plugin Installer and it isn’t showing up and it is giving me a load error upon starting up.
I see it under System Preferences but that’s the only place it’s showing up. Not in my tools.
This is the load error:
Error: #<NameError: uninitialized constant JF>
c:/users/appdata/roaming/sketchup/sketchup 2016/sketchup/plugins/greyscale.rbs:22:in <main>' SketchUp:1:ineval’


#2

Remove it from the SketchUp 2016 plugins folder, change the extension of the ZIP file to .rbz and then use SketchUp’s Install Extension to install it.


#3

This a long running issue.
But it’s easy enough to fix.

The ZIP contents are:

Unfortunately script files load in alphabetical order, and the RBS needs the menu which is set up by the RB loading what’s in the subfolder, and since that hasn’t yet run, the menu isn’t available and it fails.

Here’s the fix.
Remove any of these files/subfolder already in the Plugins folder.
In a copy of the original ZIP, rename the RB as #jf_tools.rb
By starting its name with a # that will then load before other ‘JF’ tools so the menu is then available.

Then do as @DaveR suggests, and change the ZIP into an RBZ, and then install all of the files from that new RBZ.
Restart SketchUp and all should be well…


#4

Hey SUSage,

I removed the existing files from my Plugins folder, used the BetterZip app on Mac OSX El Capitan to edit the file name while inside the zip file to #jf_tools.rb. First tried extracting the files, renaming and then re-compressing, but OSX didn’t make the zip in the same way and the installed files ended up inside another folder like “_MAC_OSX”. I renamed the zip to .rbz and installed via the Extensions tab of Preferences. When I relaunch SU, I still get the “uninitialized constant JF” error. I then went through the whole process again, but this time left jf_tools.rb named the same and renamed greyscale.rbs inside the zip to zgreyscale.rbs. I figured if it does load alphabetically, then 5 other plugins would have to load after jf_tools before zgreyscale.rbs would be loaded… still the same error :frowning:

Perhaps the download from http://www.smustard.com/products/ is old?


#5

Hi folks. I’m the author of that plugin. It is quite old. I can get it modernized but it may take a few days before I can have a look at it. I’ll post an update when ready.


#6

Hey Jim!

So you’re the infamous uninitialized constant, JF :slight_smile: Thanks for looking into modernization. Will this new version be available in the Extensions Warehouse? Something cool to look forward to over the weekend.

Thanks again!!
-=Randy


#7

Thank you, Jim. That would be great!!


#8

II did update this one but I guess I never got around to posting it. Will get it posted this afternoon in SketchUcation store.


#9

Hey, Jim. Thank you for updating this. I have a file that was saved in 2016 greyscale mode and we can’t revert it. Any chance you know how we could get it back to color? I’ve tried opening it in 2016 and using the extension, and I’ve tried opening it in 2017 and using the extension.


#10

Have you tried going into the Materials window and resetting the color?


#11

Interesting. It worked on some but not all. Good idea!


#12

I’m glad it sort of worked. I wonder why it didn’t work on all of them. Do you still have the original textures? You could replace the grayscale ones with the originals.


#13

Hello everyone,

I use this plugin and need to install it on my current machine.

However, I can’t find it on Sketchucation and it’s discontinued on Smustard.

Where can I get this again?


SketchUp in 2019: where great ideas get to work
#14

I haven’t written or maintained my plugins in years, nor do I have any plans to.

That said, here’s the file. As-is. No warranty, etc. Use at your own risk, etc. I will not be held liable, and so on.

jf_greyscale.rbz (4.4 KB)


SketchUp in 2019: where great ideas get to work
#15

Thank you Jim!