LO Model Does Not Match SKP - It Is Rotated Slightly Off Axis

I have been trying to resolve dimension differences between SKP and LO on this model. SKP is correct, but LO is not. I discovered the LO model is not aligned with the axes. In SKP everything lines up with the axes, but if I draw a reference line in LO aligned with an axis it reveals that the LO model is rotated just slightly (see the reference line at the top of the model in the LO file). I have saved the SKP model as a separate file, deleted all extra data, and sent to a new LO file, and it still happens. This one has me stumped. Why is this happening, and how do I resolve it? Any help is much appreciated.


Looking at your SketchUp model I see the axes have been moved away from the default location. I reset them. And then I checked the coordinates of endpoints in the model. Here, for example, I would expect these points to have the same Y value but they don’t.
Screenshot - 8_31_2022 , 9_13_55 AM
You need to square up the model.

1 Like

I’m on my phone so I can’t check the file, but…. Your profile states that you are using SU 21, is that stil the case. There was a change made, I believe in 22? to have the standard views align to a moved model axis, rather than have them stay alligned to the underlying global axis. This might be part of what you are seeing if you moved the axis and are using standard scenes in your layout?

1 Like

Dave, Thank you for the feedback. The top image shows the coordinates in my model of the same corner you tested. The coordinates indicate the model is square. In the bottom image I reset the axes as you did and did the same test. In both cases. the model appears to be square. However, your actual coordinate numbers are different than mine, which led me to realize that the foundation group axis was not actually resetting. I reset both the model axis and the axis of the house foundation. When I double click the foundation group, and then context click and reset the axis it then looks as though the axis is reset, but if you click out of that group and then click back in, the axis is right back where it started…and the coordinates are pulling from that axis…and based upon that axis my model is not square. Thoughts on why the foundation group axis will not reset? Is there a way to reset every axis in a model all at once? Also, since the foundation group is the one causing the trouble, it is confusing to me why when I double click into the foundation group, then create a new line that I hold to the green axis, why is the foundation group still in correct alignment with the new green line? If the foundation model is off axis of that group axis then the new green line created within that group should not be in alignment with the foundation, but it is.

@endlessfix I do need to update to skp 22, but I had a large project in permitting and did not want to update until that project would no longer require changes. Too risky to update LO in the middle of that. It is time to update. Thx for the input.

1 Like

The group has its own axes independent of the model axes. You see the group’s axes when you open it for editing. When you initially create the group the group’s axes are aligned with the model axes. It appears that when you moved the model axes you didn’t get them exactly square to the screen. Then groups formed after that would all be very slightly askew which would result in what you are seeing in LO.

As for changing all of the axes at once, you might look at Axes Tools (Extension Warehouse). There may be something else that would work but I didn’t explore them all.



Thank you again for your help. I have tried to resolve this a couple times since your last reply with no luck. More concerning is that the file I shared is only a very simple 2d floor plan section of a much larger model that is a complete 3d design. There is no way to have faith in the measurements in the rest of this model until this issue is resolved. Here is a summary of what I tried.

Following your suggestions:

  1. I reset the global axis
  2. Using the Axes Tools extension I reset all component, group axes
  3. Using the Text Tool I marked the coordinates of two corners. These coordinates confirmed the model IS square. These are the coordinate marks circled in green on the attached.
  4. Then I double click into the group with these same corners and used the Text Tool to confirm the coordinates of the same two corners. These are circled in red and show that the model IS NOT square.
  5. If all axes have been reset, how can the model be square to the global axis, but not square to the group axis?
  6. To try and test what was happening, I then double clicked into the group, did a select all, drew a freestanding line on the green axis to use as an inference line, and then attempted to rotate the group so it was square, but this could be done because the model shows as being square to the green axis of the group. Note that I would never in my workflow click into a group and then rotate it, but am trying to follow this to a natural conclusion.
  7. Finally, since the coordinates inside the group show it is out of square by 5/16” I drew a line 5/16” long, rotated my model from one of those corners to this new corner location 5/16 over, and in both the case of the global axis and the group axis my model was then out of square.

Which brings me back to, if all axes have been reset, how can the model be square to the global axis, but not square to the group axis?

Any help is appreciated.


Have you tried exploding the group, then immediately re-grouping. That should reset the group to the global axis. First you should make sure the geometry is exactly aligned with the global axis, then explode, then regroup. That should fix the issue.

NIck (et al),

I went through the model this morning and basically exploded and regrouped everything. Everything was checking out as square and true whether I was checking against the global axis or against the individual group axes. However, as I was working through this process on several occasions everything was once again reading as being off axis. Very frustrating. I started over again and this time I wrote down every move that I made to try to determine what was happening.

What I discovered is that my old friend “Scenes” had turned sinister. Although I was resetting the axes I had failed to update my Scenes. And in Scenes there is this pesky little checkbox for “Axes Location” in “Properties to Save”. Over and over again as I was flying through the model trying to clean it up I was in fact reverting to the old axes position every time I hit one of my scenes! It never occurred to me to think of Scenes in this equation as I was not changing any of them.

I believe we are on the road to recovery.

Thank you for the help.


Out of curiosity do you have color by axis selected in the Style panel?

Thanks for reminding me of the color by axis option. I have a list of items I know still need to be rotated - like the cabinets in the attached image - but color by axis makes it crystal clear what still needs to be fixed.

Color by axis is not an exact indicator of the line being on the axis, it is an approximation. The only way to ensure the line is true to the axis is to lock the axis with the arrow keys.


In that case, you can easily update the axes position for every scene…

  1. Choose the one scene where you corrected the axes.
  2. Select all other scenes (shft or cntrl)
  3. Deselect axes on the list, then select so it has the check mark.
  4. Do not hit update. You are done at step 3.

Now they will all match. You can do this method with any of the parameters in the list.