Lines shifting when grouping

Hello all,

I am a casual Sketchup user (Sketchup Make 2017) modeling my house. I am quite far into my model and have just encountered an issue. I’m not sure if it’s something I did or its a sketchup issue.

If I draw a few lines on axis and then group them (like a header or truss), the lines shift off axis and are moved by a few 16ths of an inch. Please help if possible.

Thanks!!

I tried to post pictures and it will only let me post one, and the entire model is too large to upload.

Hi,

Please post up the model so it be look at more closely.

You can use DropBox, or Google Drive, or Microsoft’s OneDrive for large files… and then attach a link to one of those.

Ok thanks. If you draw a simple rectangle on axis, then group it, you will see the lines change from RGB to black.

https://drive.google.com/open?id=1p9z_vvNnoYW18ePmdgIxVJRGL6StiTXr

Have you been drawing geometry directly onto various Layers?

… Meaning that you select any random Layer name and then start drawing directly onto that one with all of your modeling?

No, I only draw on Layer0.

Oh, Good That’s perfect then!!

Some of your model disappears on my computer, and I was wondering about that.

I do see different orientations for axis directions… and you’re generally modeling in a reverse direction from what I’m used to doing… and the Parallel Projection (Camera Setting add to an interesting perspective)… so I’m trying to get myself centered in this new world you’ve shown me. :slight_smile:

I’ll report back with what I can find out. and of course others may solve this before I do, so we’ll see…

Thanks for your help, I’m just teaching myself as I go, so I’m not sure if the settings I use are the correct way lol.

15 Justin Court (JimD Alt).skp (2.8 MB)

Okay, I’m not claiming to have fixed the original model, here… All I’ve really done in the attached file above is to copy and paste your model into new sketchUp file.

The two original scenes you’ve set up are missing in this one. and so are a few of the components that were sitting in component tray but not being used.


From my perspective I keep finding issues with how the Scenes are working. When I originally open up the model I see the rough framing with it’s axis colored edge settings turned on. BUT as soon as I change to another scene all that stuff disappears (and doesn’t return again).

However, your other more complete model appears for the first time… and I’m left wondering what the difference is between the two versions.

You’re original comments are about Shifting Lines… and I’m trying to find out which version of the drawing I should be looking at.

The rough framing only (with the axis line color applied)?

… Or was that abandoned in favor of the more complete version? (…which so far seems okay from what I can can tell.)

If possible please add in some attached text to pin point the problem areas on the model.

I don’t have access to the model at the moment, is it located a long way from the SU origin?

No, I checked for that, Box it was within 100’ of the origin point.

There were two Axes directions going on. the standard XYZ (with Red point to the right, Y receding into the monitor)… BUT, within some the groups/components they are rotated w/ X point to the Left, and Y point to us).


I also tried to select all and zoom to selection in order to find an outlier placed way off in the distance but that didn’t uncover any additional geometry either.

you can use the text tool to see where the coordinate points are for each endpoint.

In the top picture (this is a screen capture from your original file where the header has the black outlines instead of green). BUT, after copy /pasting that model into a new file that same header is no longer out of plane and appears just fine.

…and the top plates (in the lower photo) now have a discrepancy of .0081" out of parallel on the z axis.

At some point you have changed the model axes and the z plane is ~0.005 off.
This tiny a change would allow things to snap out of alignment and still fall withing the tolerance of the rather inaccurate colour by axis.

1 Like

Thanks everyone. So what can I do to repair this? I don’t understand why everything lines up, until I try to group them or move it.

Edit: The scene I made was an experiment that I forgot to delete. Also, I can’t download the model posted because its a different version from mine and I can’t get the new version without paying.