Lines in extruded arc


#1

I attach an extract from a drawing I have just done that includes a cornice. Although the section is identical, the higher level cornice shows lines where they shouldn’t be.

I constructed the lower cornice first by drawing the section using 2 point arcs. I then drew a line around the building and used that as the guide line to extrude the section using Follow Me.

For the upper cornice, I used a slice from the lower cornice as the section. Perhaps the slice does not create arcs in the same way as when working from scratch. In which case, is there a proper way to do this without recreating the section all over again?

Cornice.pdf (28.6 KB)


#2

Hi simoncbevans, hi folks.

Personally, I would try to construct the whole profile for the cornice before following it around the building.

However, it would be better if you can post the sip file so we can look what might be going wrong.

Best regards.

Jean


#3

The curves in the profile are exploded after the Follow Me operation. The line segments in the slice wouldn’t be welded together.

There are several options to deal with this. In the existing model you can select the geometry of the top cornice, right click and choose Soften/Smooth. You probably won’t even need to adjust the softening angle.

Going forward, if you know you’ll use the profile more than once, copy it before running Follow Me so you have a second copy to extrude with welded curves.

You could also select the edges in the slice and use a plugin like TIG-Weld to weld them together before extruding.


#4

Hello Jean

Thanks for response.

I guess you meant the SU file? I tried attaching it but it was too big.

To explain better what I did: because I had already created the section (whole profile) and used it to extrude for the lower cornice without keeping a copy, and because I wanted an exact replica, I drew a rectangle at right angles to the cornice and used Intersect with Model to create a new slice. I then deleted unwanted parts of the rectangle and used the remaining section for the top cornice.

I’d be happy to be told there is a more elegant way of doing it (other than remembering to keep a copy of the original section, say).

Simon


#5

Simon, I offered you several options for dealing with it. None of those were “elegant” enough?

If the profile is one you would use in future models, too, why not make a component of the profile and save it so you don’t have to draw it again?


#6

Unfortunately not, unless redrawing the thing can be called elegant. Of course you could try using the free Weld plugin for the arched parts of the profile, or just select the faceted cornice and use the Soften Edges slider to smooth them.

Anssi


#7

OK, there’s great advice here from both DaveR and Anssi. I think the lesson is to keep a copy and maybe put it on an Always Off layer. Sounds like the Weld plugin would be a good option too for this and other similar cases.

Simon


#8

Why would you keep a copy on an “Always Off” layer? Just make it a component and keep it in a library so it is available to other models as well.


#9

DaveR

I could keep it as component, for sure. The only reasons not to are that it is likely to be a one off and I don’t want to clutter my library and so make it difficult to find things. If it’s in the drawing, I know I can find it easily. Call me mad!

Simon


#10

Update: just tried to download Weld and I am told it is not compatible with SU 2016. Shucks!


#11

Even if you aren’t going to use it in other models, just make the profile a component. It’ll reside in the In Model library available for use the next time you need it. Certainly no need to give it a layer association you will need to change later.

Weld is compatible. It just isn’t signed. It’ll still work. Quit giving up so easily.


#12

DaveR

You’re right of course. If I make it a component and delete it from the drawing, it will still be in the In Model library, right?

I’ll also try Weld now you tell me it’s safe.

Thanks again,
Simon