Line with the dimension and the angle

mac

#1

HI,
I just downloaded SketchUP and I am trying to use LayOut.
I use Draftsight.
I am trying to draw la line using the length and the angle and I can not do it.
the command used in Draftsight is @length,angle
What is the exact chain to type in the command box on the lower right corner to get the right line.
Thank for your help.
JP


#2

You can draw a line and rotate it to a given angle if you like. Or you can enter the relative endpoint coordinates if you know them. LayOut is not a CAD program like Draftsight. It is a tool for creating documentation from SketchUp files.


#3

Hi Dave.
Thanks very much for your help
I am trying to draw the line as it is described on the tool Help but when I type:
<43,10 the chain is refused as no valid.
Would you know where the mistake is?
Thanks again
Jean Pierre


#4

There’s a big difference between < and ^. Try the latter.

A screenshot from the Help article.


#5

Hi jpmarty, hi folks.

Have you set your regional settings to use , as the decimal separator and ; as the list separator ?

If so, separate the two values with a semi-colon ;

Regards.

Jean


#6

Hi everybody.
I think the problem may come from the fact I did not set my regional setting.
But I have no idea how to do it…
Can you help me on that, too.
Thanks in advance.
JP


#7

Settings->Language & Region

(which may already be translated to something if macOS automatically detected some region for you).


#8

Thanks.
But that has to be done on the Mac settings, Not on LO settings, isn’t it?
If so, it should be done since my keyboard works properly.
But when I try to type ^on the LO dimension box, it doesn’t work…


#9

Yes, that is macOS system settings. Keyboard preferences can be selected independently of basic region settings. I don’t think LO has its own separate region settings.


#10

thanks.
This is already done.
But there is no way to type ^ in the dimension box


#11

Can you type ^ in other things such as a text editor? Just exploring whether this may be an aspect of your keyboard as opposed to Layout itself.


#12

Hi,
Yes, it works on Pages…
But noway on LO


#13

Hi Jean-Pierre, hi folks.

By your question I deduct you don’t have a keyboard that shows the ^ character.

Do you use Mac OS in French or English ?

I use it in French but I will try to guess the English equivalent ? I am asking because of your name which appears French to me.

Try this:

1 - Open the System Preferences from the Apple Menu.

2 - Click on Keyboard.

3 - On the dialog window that opens, check the last checkbox that offers to shows emojis, symbols and keyboard layout on the menu bar.

4 - Close the dialog window. A new icon appears on the menu, on the right side.

5 - Click on the icon.

6 - Try the second choice that should be something like keyboard visualizer. A small keyboard image shall appear.

7 - If you don’t see the ^ in the small image of keyboard, try pressing the Alt key or the Shift key or both Alt and Shift and observe if the ^ character appears.

8 - If nothing works, try the other menu choice that offers to show emojis and symbolsi.

9 - Choose Punctuation. You shall see the ^ character.

10 - Click on it and the description shall show CIRCUMFLEX ACCENT. You may even add it to your favorite.

11 - Double click on it and it will be inserted at the cursor position in whatever program you are using.

Regards.

Jean


#14

Bonsoir Jean.
You are wright: I am French But…
I use a Spanish keyboard because I live in Spain.
I do have the ^ character on my keyboard and I works will all software except on LO.
This is very strange…
thanks for your help
Hope we are going to find how to solve the issue.
Jean Pierre