Lights cast weird shadow lines on walls when I render in Vray

If I activate shadows on my lights, I get these weird lines.


Without shadows, the underside of the stand up counter catches tons of light

Any solutions?
Thanks

What version of SketchUp? What version of Vray?

Your profile indicates a SketchUp version that doesn’t exist.

I’m using Sketchup Pro 2020
And Vray 5 for Sketchup.

Could you fix your profile?

What settings are you using for the render?

I’ll sort the profile.

Settings are…
Quality: High
Noise limit 0.1
Global illumination is on (Brute force, GI Depth 9)
Everything else hasn’t been played with since I downloaded and opened the program.

Are there any other settings you’d like to know?

Actually, I can just screenshot it…

And the lights in this scene

@eric-s will probably be able to give you the best advice regarding this.

To me it looks like the render hasn’t completed.

I’m running another one now to see if a lower setting (medium) makes a difference. The original screen shots were from finished renders.

V-Ray appears to be functioning normally here. When you mention:

It sounds like to me that you’re referring to the shadows that the top part of the counter are casting beneath the gap. That’s normal. If it feels too dark to you, I’d recommend not letting it slow your workflow down and instead correct it in post-production. See example below where I just lightened the shadow…maybe by 50%.

Here’s the comparison between original and lightened version.

Apologies, I mean the lines on the walls. Those strange bands that get tighter as you get nearer the ceiling. The wall is a solid colour so I’m not sure where they are coming from. When I switch off ‘shadows’ in the lights, they vanish (but I lose my shadows).

I’m in the process of running a render where I deleted all the individual lights and just created one big rectangle one in this room, and yep, they are appearing again as I speak.

I saw someone else on this forum had the same problem, but there was no answer so I opened a new topic.


The exact same weird lines on their blue walls.

Any help would be most awesome.

Try uploading you model here (via google drive, dropbox, etc). Too many factors to know for sure from a screenshot.

Will do. Here’s the link

Ok, I think I have it figured out. That patterning on the walls is just noise from the render. You have your render settings set to ‘Progressive’…that means it will just keep rendering until you stop it so the Denoiser hadn’t kicked in. So turn Progressive off and make sure your Denoiser is kept on. See if that does it.

Without Denoiser.
Screen Shot 2020-11-30 at 9.09.38 PM

With.
Screen Shot 2020-11-30 at 9.09.13 PM

I also noticed a few things that need fixing in your model as well.
This image kinds of sums it up:

  1. Turn on Monochrome Face Style and see all the reversed faces. Those can give V-Ray trouble. Make sure to always reverse your faces so that the front (white) side is facing out.
  2. Most of the geometry is ungrouped. Make sure to group everything. I often explode and re-group my model by material as that makes it fast to assign new V-Ray materials later.
  3. There is no ceiling thickness. V-Ray doesn’t like single face walls so make sure to extrude them all.
  4. Your rectangle lights are touching the ceiling face. Sometimes that’s ok, but sometimes it’s better to pull the light off the surface and insignificant amount, like 0.1" so there’s no Z-Fighting issues.
  5. The camera angle you’re rendering is odd. The viewer is 7’4" tall and looking down at the floor. Unless that’s done intentionally, I’d suggest bringing the camera down to 5’6" and use ‘Two-Point Perspective’ camera view in SketchUp for a better composition…

Existing view:

Proposed:

3 Likes

I ran a render with progessive off and yet the lines remain. Could there be something else.
Nice one on the 2D, looks well better

Did you follow Eric’s advice?

I lowered all the rectangular lights by 2 cm, I set them all with the same brightness and in rendering those stripes no longer appear on the walls. I also set them ‘Invisible’

Even with ‘Progressive’ activated those stripes no longer appear.


And even if I leave them visible, those stripes still don’t appear.

And I deleted all the other lights that don’t appear in the room.

1 Like

That worked a treat.

Thanks so much for the help, I have line free renders and the other stuff is incredibly handy also. You guys are awesome.

1 Like