License error with Sketchup Make?

Sketchup greenhorn here.

I’ve been trying to launch Sketchup Make but it crashes when I hit the “Start using Sketchup” button. Actually, it launches a new drawing window but then the whole program crashes in less than a second. When I relaunch, I get the following message: “Sketchup cannot start due to a license error.” When I relaunch and hit the “License” tab, the display reads “Licensed to: Sketchup Make 2015 user.”

When relaunching, my Mac gives me a problem report, which is gobbledegook for me, but one thing I was able to garner, if it helps, is that I’m running Sketchup 2015, version 15.3.329. My Mac is running OS Catalina 10.15.7

Things worked fine the last time I used it, just a couple weeks ago.

Any ideas? What info can I give to help the process?

If it worked fine a couple of weeks ago, then it has to be an issue with the OS, automatic update perhaps. See if you can roll back to a date when you know it last worked and see if it resolves.

Basically, I don’t think SketchUp 2015 is supported on OS X 10.15.7. If it worked before, it might be an issue of corrupt preferences files.
Have you tried installing the newest version of Make (2017)?

You have conflicting information. Your profile states a windows OS, your post mentions Mac. Please correct your profile.

1 Like