Sketchup cannot start due to a license error (Make 2015)

licensing
startup

#1

I’m seeing some bizarre behavior when I try to start Sketchup 2015. The first time I start it I get a small window with the error “SketchUp cannot start due to a license error”. I click OK and start SketchUp again, and it works normally. Once I Exit SketchUp and try to restart, this repeats. First time give the error, second time it starts up with the typical Make “Start Using SketchUp” screen and all is good until the next restart.

I’m running Mac OS X 10.10.2 on an iMac and using the most recent version of SketchUp make.

I’ve uninstalled and re-installed, including removing the ~/Library/Application Support/SketchUp 2015 folder. Disk permissions are all verified and correct. I also tried to install and then uninstall SketchUp Pro, the re-install SketchUp make. Nothing has made a difference.


#2

Well isn’t that strange. You have already done some great things, go you!

Did you install Make from this page? http://www.sketchup.com/download/all

It’s probably a permissions issue and repairing permissions may fix this error. If SketchUp does not seem to be retaining your license information, I recommend repairing your disk permissions by following the steps below:

  1. Restart your computer.
  2. Open a Finder window.
  3. Click Applications.
  4. Click Utilities.
  5. Double-click Disk Utility.
  6. Select your hard drive.
  7. Select the First Aid tab.
  8. Click Repair Disk Permissions.
    9. Please repeat step 8 until you no longer see new errors during the repair.
  9. After the permissions are repaired, exit Disk Utility.

Repairing your disk permissions usually solves this problem, but please let us know if the problem persists.

Thank you, AlexB


#3

As I stated in my original post, all disk permissions are correct. However, just to be thorough, I re-ran the disk utility tonight. There was nothing to fix except a couple of known messages that should be ignored (ACL found where one is not expected, for example).

I also installed the new version tonight. Same error.


#4

I’ve just spent £150 on a new hard drive because I was told it was to small, a new installation of windows because it could be a virus, all to find out sketchup 2015 make licensing has a floor in it. I was trying to learn how to use it to draw woodwork things so its back to paper and pen.


#5

I have the same problem, but in my case on a Windows7 PC. The error ‘Sketchup cannot start due to a license error’ apears after the first login screen, where i can register my license (i registerd and that works) After 'Start using Sketchup, the PC crashes after a few seconds… It hapens every time…
In save mode i see the error ‘Sketchup cannot start due to a license error’

I have reinstalled and installed the 32 bit version, the same problem.


#6

network interface controller disabled?


#7

Well. I have a correct working network connection.


#8

LAN or WLAN?

enable NIC of LAN if disabled.


#9

I am working on a laptop and SU crashes both when I use the WLAN and when I disable WLAN and are connected using a LAN cable.


#10

try if launching SU by “right-clicking > run as admin” helps.


#11

I am so frustrated! I was using a trial version of the software for personal purposes. My trial license expired last week, but i was able to still open files and use Make. I downloaded a human figure from the Sketchup site, and used it in one model. Since then, I am unable to open any files. The program freezes on launch. I have tried deleting every file related to Sketchup and doing clean installs (about 10 times). I have run disk utility, and it says everything is fine. I tried updating system software. I restarted. I tried everything I could find on forums. No luck. When I open the software it opens with a new template and I can use that file, but if I try to open a previously existing file, it freezes. Help! Thanks.


#12

probably a bad OpenGL support of the driver of the used video card, try if disabling the hardware acceleration from inside SU by “Window > Preferences > OpenGL…” helps.


#13

that file sounds like it has a problematic Material in it that your mac doesn’t like, can you post the skp or a link is it’s in the 3D Warehouse…

john


#14

if you can open a previously created file with the OGL hardware acceleration disabled, try if enabling “View > Edge Style > Depth Cue” allows to switch the hardware acceleration on again.


#15

I was finally able to fix the problem. Three were two Sketchup files in Preferences in a Library that could only be accessed by hitting Option-Go menu. Once these were deleted, the program runs perfectly again.

Thank you for your input!