Libfredo 6 animator ffmpeg problem

I’ve tried so many ways to download ffmpeg for mac. Ultimately I’m getting a package that has ffmpeg unix executable files in the bin that don’t work and can’t find ffmpeg exe anywhere in the package as all the help videos indicate to exist as described below. I’m stuck with awesome animator videos that I can’t convert to mp4. Any help to resolve this will absolutely be appreciated. mac os high sierra 10.13.6

-You can do it from Animator.
You just need to install ffmpeg (basically copy the exe file to the plugin directory), as described in the manual attached (also in the menu of Animator).

Than you can generate the video as MP4, GIF, MOV, etc…

FredoInstructions_ffmpeg_Mac.pdf (491.9 KB)
Instructions_ffmpeg_Win.pdf (512.2 KB)

Hi @yonofun, I was able to find the .exe in the bin folder by visiting here and downloading the windows build. There are Mac builds available there too. I am hoping that the link will work for you.

Thank you. I’ve utilized this download and others from the same site. I don’t know what I’m missing, but it’s been days of trying. I just used your link and here is what I get
In the bin are 3 files ffplay, ffprobe, and ffmpeg just like all tutorials show. Trying to choose ffmpeg. Only they are unix executable files rather than exe files and from animator where the option to find ffmpeg is clicked and I direct to the bin and see the three files they’re not available to choose and I’m at a dead end. It seems it should be an exe in order to be available to select but it’s unix executable. I wonder if using mac’s archive utility to unzip the file could be the issue. Sounds unlikely.

Hi @yonofun,

I see that you downloaded the Mac build, my apologies for overlooking that. I downloaded the Windows build and just checked to see if it was a windows executable and it looks like it is.

I am not too familiar with how things would work on a Mac so please do let me know if you and I are looking at the same thing but I have misunderstood what might be going on?

As I understand the instructions, you would use the exe version on Windows, and the Unix executable on Mac. What happens if you put the ffmpeg file into ~/Applications?

1 Like

I installed Animator, figured out how to get the camera panel and how to export a video, before putting ffmpeg into the right place. Sure enough I got the version of the export dialog that doesn’t know where ffmpeg is. I copied the ffmpeg Unix executable into ~/Applications and used the find ffmpeg button to point to that file. After that the export dialog looked normal, and I could export an MP4.

But, it would not preview, and I think would have failed in the end. To solve that I double clicked on the ffmpeg file and also went into System Preferences, Security & Privacy, and in the General tab I gave permission for ffmpeg to open:

I still had some trouble with the preview video feature, or opening the folder, but I was able to find my exported video in an Animator Videos folder in my Downloads folder.

1 Like

That sounds right. I have tried the ffmpeg file from applications with the same result. When I navigate from the find ffmpeg button in animator and get to the bin file then choose ffmpeg nothing seems to happen. I saw in a libfredo6 vid that the find ffmpeg button disappears once successful and you’d then be able to choose the file format you’d like to convert to.

It’s worth noting that /Applications and ~/Applications are two different folders. He specifies ~/Applications, so that’s where I put the file. On Mac, ~/Applications is the same as /Volumes/hard drive name/Users/your user name/Applications

1 Like

THANK YOU!!! It’s been a frustrating few days. I made a mess of multiple files trying different fixes. I just cleaned up everything to the trash bin, emptied it, downloaded ffmpeg, followed advice to open preferences at the same time, found the correct root directory to file (/Library/Application\ Support/SketchUp\ 2018/SketchUp/Plugins/ffmpeg-20200106-1e3f4b5-macos64-static), closed and reopened sketchup, regenerated video and to my disbelief I’m watching my edit in mp4 format. So relieved. This is great. Thanks for the help, I was losing hope :slight_smile:


thanks for reaching out, I’m unfamiliar with windows to reciprocate. lol. I was able to resolve the issue so I’m grateful for the activity in this thread.

1 Like

He does give alternate locations for where the file goes. In the folder you used it will be ok for SketchUp 2018, where I put it would work for all versions of SketchUp. Also, you only need the ffmpeg file, all of the other files, and the folder itself (ffmpeg-20200106-1e3f4b5-macos64-static) are not needed.