Leaders & dimensions chaotically and unpredictable scatter

I recently updated my model reference in Layout, only to be greeted with the following result:

Luckily I managed to save within a few minutes of this and just closed without saving. The next model update had better results… That said, this is an issue that has caught me less fortunate at other times.

More commonly I am finding my dimension lines tend to move around a lot when updating my model reference as shown in this image:

Just another example of why Layout is a serious headache when it comes to professional use.

1 Like

There is a reason for this behavior, upload the Layout file for an examination and explanation.

1 Like

Yes obviously there is a reason.

I am open to feedback, here’s what I know:

In the first example, I moved a section cut slightly so that some of the geometry that was previously cut-through was no longer cut through. Further in depth, I am using Curic’s wonderful Section tools to generate tag-based hatching in my drawings. If I adjust the section plane location or otherwise update the geometry at all, the plugin creates a new group with new 2D linework, filled regions etc. So all of the leaders that were pointing to the face of an old hatched region, no longer have that specific face to snap to (see complaints about face snapping).

In the second example, The section plane never had to move, I just modified the locations of some of the windows in my model. In updating the section cut linework with the same plugin, again, it creates new 2D geometry which throws all of the snapped dimensions and leaders off. Often times because the Dimensions were correctly snapped to an endpoint, Layout does a decent enough job “reconnecting to geometry” but it often shakes up all of my previously clean, organized dimension strings.

My best solution is to set a keyboard shortcut to disable object snap in Layout so I can avoid the leader points from snapping to faces. This is massively annoying because even if object snap is turned off, it is turned back on the second I edit a leader point, meaning I am having to turn it off every time I place/adjust a leader. Obviously this solution is not going to work with the dimensions, as I need accurate measurements that are snapped to the geometry, and so long as my section geometry isn’t too different than it’s previous state I just get the occasional unreferenced dimension, conveniently highlighted in red with every other dimension on the page - now that I have new 2D section geometry.

1 Like

Is there a fix for this yet? I’ve been having this exact issue right from the beginning with v2022. The advice I was given by tech support when it first happened to me was to go back to using v2021. Hopefully there is a fix by now. I was hoping v2023 would come out soon and have this resolved.

One work around I found was to

  1. Deactivate “Auto Scale” on all dimensions and set to the correct scale manually. You can select all the dimensions and do this in one step.
  2. “Make Group” all leaders and dimensions (I do text as well just to keep it all together.)
  3. Copy using “Ctrl + D” which offsets the copy exactly 4 “Shift + arrow” clicks to the right and down.
  4. Delete the original group and move the copy precisely in place.

This strips away any snapped anchors to the model. Of course you lose the ability to have your dimensions and leaders update when something legitimately moves in your model, but that is better then having random scatter happening which can cause significant errors in professionally liable work. Note, every time you add or modify a leader or dimension, you’ll need to do that within the Group and then copy - delete old - and move back in place again.

This is all too much work for something that should not be acceptable behavior. I love SketchUp and use it daily, but this error is dangerous and needs to be addressed. Please let me know if a solution already exists, and if not, please prioritize fixing this issue as soon as possible.



2023 is here, fingers crossed…

1 Like

A quicker way I realized is to simply cut all dimensions and leaders and paste them back in place. This strips away all snapped anchor information in just two steps. Of course “auto scale” needs to be deactivated and you must select the correct scale manually.

1 Like