Layout viewports go black in 2022 but work fine in 2017, what's wrong with 2022

My old version of layout (2017) allows me to click into a viewport and make changes to the sketchup model. In version 2022 the viewport goes black. Is there some setting changes between the versions?

Share the LayOut file so we can see what you’ve got. There was a change a couple of versions back to prevent double clicking into a viewport to change camera position. Except for one-off exports, you should not be changing the camera position in the LO viewport. That an create huge problems for you.

01.05.23 Wilson ADU Revisions.layout (7.2 MB)
Here is my 2022 Layout.

I see the black when double clicking into the viewport. Again, you shouldn’t be double clicking into the viewports.

If you absolutely must do so, change the style to a default one instead of the sketchy style while you work. Change it back when you’ve finished.

FWIW, I checked the SketchUp model files and found the following.

Incorrect tag usage.
Screenshot - 1_10_2023 , 5_30_45 PM
and unused content.
Screenshot - 1_10_2023 , 5_31_00 PM

Fixing this reduced the .skp file by 64%

In the other file,
Screenshot - 1_10_2023 , 5_33_48 PM

and
Screenshot - 1_10_2023 , 5_34_15 PM

Reducing the file size by 57%.

Thanks, Dave.
Do you know why Sketchup eliminated the double click into viewports? I am disappointed in losing that functionality.
On the purging, what steps did you take to do it. I do purge, obviously not correctly.
Thanks again.
Neitha

They didn’t eliminate this function but they made it so by default you have to enable it. the reason is that changing the camera positionin LayOut can create issues. This is not new to newer versions of LayOut. here’s an example where I’ve further modified the camera position for the viewport in your LO file.

Note what happens to the labels and dimensions when the Camera properties are reset. Most often it’s worse than this.

Best practice has always been to avoid modifying the Camera properties in LO.

I first used a plugin called Default Layer Geometry to fix the incorrect tag usage. Then I used a plugin called Purge All to purge the unused stuff from your model. I use this plugin because it generates the report I showed. If you don’t care about the report, though, you can use Model Info>Statistics>Purge Unused and get to the same point.

Thank you, Dave.
I appreciated the information and your time to provide it.

1 Like