Layout Vector Export To PDF Bug

I’m having a frequent problem that occurs when I export my layout files to .pdf. The export seems to miss a vertex (or two) and thus, instead of the drawn line reaching a corner, as expected, it is drawn at a diagonal (see drawing). This only happens when the drawing mode of the model is set to vector. Raster doesn’t seem to have the same problem.

In this particular model, I can stop the diagonal lines from happening by removing the two short vertical objects, nearest to the diagonal lines. This isn’t a solution though, as they need to be in the drawing.

This is a real problem, as I need my models to be exported as vectors. It’s happened on multiple models and I cant seem to find a workaround.

I’ve attached a sample .skp and .layout which reproduces the problem.

Any help much appreciated.

SKL - Export Prob.layout (242.8 KB) SKL - Export Prob.skp (430.7 KB)

I unfortunately do not have a solution.
But would add, it has been my experience sometimes it actually shows the unwanted lines in the LO viewport window prior to export to .pdf…sometimes not.
I currently have a file exhibiting this very thing and it is tiresome to fuss with it only to settle on raster for output when all adjacent LO viewports on same sheet/project are all in vector format.

Charlie

Thanks Charlie, I’m glad I’m not the only one getting this issue. I agree with the point you make that sometimes the unwanted lines appear in the .pdf and sometimes not. I’ve found more often than not on recent models but certainly, there have been occasions when the .pdf has been ok.
Hopefully someone has a solution.

Dan

Check this thread, also:

1 Like

For clarification:
I find when I see the unwanted lines in the .pdf…sometimes they present in the LO viewport…sometimes not…that is to say…if they are seen in the .pdf…they may NOT be present in LO viewport.

Charlie

Thanks for linking to this. I did a search before posting and I didn’t spot this.

1 Like

@dannorris

I looked at your model and , Although we are still looking at this rendering issue, if you change the settings in the Model dialog and then set them back, does this correct the vector render issue?

2019-10-01_07-38-35

CD

That is similar to a suggestion I made in the other topic. Unfortunately, doing a save and then reopen of the LayOut file brings the problem back. Also, even in the best of cases exporting a PDF on Windows still showed the artifacts.

I tried this a few times and in a few different orders and still the output .pdf has the same drawing issue.

This has been my experience as well…and why I just set viewport to raster and just accept that I have to do that so it exports to .pdf correctly.

Charlie

Have you tried adding or editing a clipping mask as suggested in the thread that Mike Wayzovski linked to?

I tried the clipping mask this morning and it didn’t help unfortunately.