Layout is very slow (doesn't want to open, and it takes forever)

Hello !

I have a plan to finish for today , and for some reason i dont know , today my layout file is very slowwww i restarted my computer many times and still slow to open the file.

I saw that the file is actually 983 000 ko… i mean the only reason that i can understand that is heavy it is because of my images … exported through enscape… ) is there a way to reduce it?



There is probably a wayt to fix it but it depends on exactly how you’ve created the file. Share the file via DropBox or We Transfer so we can see what you’ve got.

You marked the topic as solved Does that mean you don’t need any help with it?

No no ! i need help of course!sorry maybe i click by error on the check.

Then you should untick the Solved button.

I looked at the contents of your file. It looks like the main issue is the three huge SketchUp model file references. I’m still waiting for the LO file to open and it may be that reducing the size of the images will help but I think you would do well to look at putting your SketchUp models on a diet. There are monstrously huge texture files in the first .skp file I looked it.

Those huge textures won’t do you any good.

When I get the LO file open and can examine it better I’ll probably have more for you.

I finally got the LO file open. Your images could indeed be reduced in size and that would help a little. First image I saw in the LO file is this one. On the page it is 21.2 cm wide. For the resolution you have selected it wants to be almost 68 cm wide. Much larger than it needs to be. You could resize the images in an image editor to suite the size you’ll use them in the document.

I reduced the size of the largest texture images in the SketchUp model I referenced in my previous reply. That alone reduced the size of the .skp file by 52%. I expect you could do a lot of simplication in your models which would help.

Even just purging unused content from the LayOut file’s References list reduced the size of the LO file by 25%. That’s without resizing any of the references.

1 Like

Ok i see , can we make a meeting of 5 min so i can juste make sure i understand all of my issues ?

Thanks :slight_smile:

I’m sorry. I can’t do that right now. Maybe in about 3-1/2 hours.

ok ok ! do you have the file with the little corrections you’ve made ?

It’s not finished yet.

ok thanks let met know :slight_smile:

1 Like

Sorry to bother you again hehe … its just i need to send this plans by 5pm so i was wondering if you think it will be send soon :frowning:

Unfortunately not at the rate it’s going. While I’m occupied working on a paying job I’m also working on your file but as you said, it’s very slow. It’s been showing a Not Responding message message for a long time because it’s updating viewports from one of you bloated models. There’s still the other two to deal with as well.

Sorry. I’m not going to be able to meet today. I’m getting dragged away for something else. I sent you a PM with a link to the purged file. It’s more than 50% reduced from the one you shared. It’s still huge but I hope it will open faster.

Hello Dave !

Thanks for your help!
I dont know if today or next week you have time to meet so i can make sure what the best way to work on layout , in my case ,

Thanks in advance!

I opened the layout purged but i see i can’t relink a sketchup from my view ? the option is in gray so i cant do it…
Do you know if there is a way ?


did you save the new file with a different name?

I cant get your file to even open, one suggestion I will give you is… if you notice one page being super lagged try putting that reference in its own separate layout file as not disrupt your other pages, I always make this a practice if a have a 35 page set of CD’s I will divide up my layout based on models.

As an example i may have 9 pages in one layout file 1-9, my other layout file i will leave 9 blank pages to keep my numbering system easy to merge files and my page count stays accurate.

FYI if you are storing files across a network, having the *

document setup panel Reference page

  • open can bring a Layout to its Knees… I fought that for years before I figured that out on my home machine from running SKP and LO locally while storing documents on my work server

We should be able to do that but I need to check my schedule. We’ll talk via private messaging.

You first need to select a file in the References list. Then you should be able to click on Relink. If you relink any of the files I updated in the LO file I shared you’ll undo the changes I made. If you want to replace your original references with the onesI modified, right click on a viewport or image and choose to open the file. Then use Save as … in SketchUp or your image editor and save the file to the desired folder. You can then relink to the just saved file by selecting it in the References list and choosing Relink.

It Seems that all the best practices of clean operation: material size, unneeded geometry, purging your model, light styles, and especially turning off not needed tags per scene, and so on, needs another video, maybe even a special topic for this, in the help centre.