LayOut Dimension Line Offset Distance

I am producing drawings from someone who requires the dimension rows to be a set distance away from the drawing. The first row shows the dimensions of the internal walls, the next shows the windows and doors, the outermost row shows the walls etc. Is there a way to offset each row at a set distance from the drawing? They want the first row to sit 15mm away from the drawing, then the next row at a further 10mm and the final row another 10mm away. I know I can put a grid on and eyeball it, but is there a way to set the distance?

Someone else might have some other clever way but as I understand it, you can only do this by creating offset lines at the required distances and snapping the dimensions to them of after you have created a dimension you can resize it by typing the precise offset.


Change the dropdown that says Gap to Length and adjust the length as needed.

This is what happens when I do that Box – is there something I’ve missed?


If you set the parameters before mouse down on the starting point, that doesn’t seem to help.

Maybe I’m misunderstanding.
I just change the length before creating the dimension and move it out till the lines fit, it isn’t snapping to a size but gives you something to align.
GIF 17-04-2024 7-02-59 PM
Sorry there is an odd pause in the middle of that, and yes I didn’t specifically align the first one.

How do you know how far away the dimension is from your drawing? I’m trying to get the dimension (so 1.52m in your example) to be positioned 15mm away from the drawing. Then your 3.04m to be a further 10mm away from your 1.52 dimension.

Doesn’t gap to length just dictate where the dimension line starts? That’s not what I’m trying to do. I want the whole row of dimenions to be positioned 15mm away from the drawing. When you start creating a dimension, in the dimensions box it tells you how far away from the drawing you are (offset). However, when I try to type the dimenion of 15 in that box, it doesn’t do anything.

I see, that makes sense, thank you. I feel like I should just be able to type 15 in the dimensions box in the bottom right hand corner of the screen (offset) but when I do that, and hit enter, it doesn’t do anything!) And it won’t snap to 15.

Adjust it before adding the dimension.
GIF 17-04-2024 7-15-15 PM
Also after creating them you can select a bunch of them and change the length to say 5mm and they will stay in place but shorten to look like your original.

Actually, you can do it by typing but only by selecting the Dimension and moving it. So you could slap them on, them move them back to the line and move them out by 15mm by typing and hitting enter.

I’m sure @DaveR will wander along and say, no, just do this.

Actually, I have just tried this. I’ve set the dimensions to Autoscale 1:1 and tried to drag out a dimension of 15, but it just keeps jumping from 14 to 19 and I can’t get it to land on 15. Any ideas?

Okay, I see. This isn’t working for me like this - the lines keep snapping so I can’t get them to sit 15mm away from the drawing. How are you recording those little video snippets please?

So you scale the dimension, type 15mm and it jumps to 14mm or 19mm or from 14mm to 19mm?

I use ScreenToGif.

I can either put it at 14mm away or 19mm away, nothing in between. I’m on a mac so can’t use the screentogif, but I may switch to my windows laptop. I’m not convinced SUP/ LO are as reliable on a mac!

You may have snap to grid on.

This may not be perfect but it works.
If you start the dimension then com back to the point it shows 0 offset but it in my case it appears to be 2mm, so I can then move the relevant dimensions, 13 and 23 mm to get 15 and 25.
GIF 17-04-2024 7-47-20 PM

1 Like

very much appreciate the in-depth tutorial on this topic.

Was wondering this very thing recently.

I would like to add, that I have had some success in building the exact offsets around a small space in a Scrapbook. Then I am able to eyedropper the right dim setting before I run that string. This eliminates the need to do it in every project.

1 Like

Maybe you could utilize grid snapping for this.

1 Like

UPDATE: I’ve turned off grid snapping and object snapping, and now I can just watch the offset distance in the dimensions box in the bottom right hand of the screen as I drag the dimension out. It won’t let me type the number to set it, as you can in SketchUp, but it seems to have resolved the issue. I had to zoom in quite closely to be precise enough to get it to land on 15mm exactly, but it does seem to have worked.

Thank you so much to all who contributed to this thread. Its appreciated.

Turn Object Snapping back on so the dimension anchor points will snap to the model.

1 Like

Ah yes, thank you!