LAYOUT - can't orbit viewport within LO

I’m finding suddenly when I double click into a viewport to alter the viewpoint it doesn’t behave as I’m used to - it used to default to orbit, and i could pan and zoom from that. Now it is defaulting to pan, i can still zoom, but can’t use hotkey to make it orbit. Is this a change? Is anyone else having this problem? This is an important part of my workflow. thx.
test.layout (544.2 KB)

I have this enabled. This must not be the problem…

I have litigated whether modifying our viewports is a good idea on this forum before; it’s not a risk if you know how to do it.


If you don’t have a wheel mouse, the different camera tools can be found in the right-click context menu inside the SketchUp viewport. I don’t know about shortcut keys as I don’t need them.

What Ansii said tells you where to switch to Orbit.

A lot of users were accidentally going into a viewport and altering the camera direction. In the case of Parallel Projection scenes that can have a dramatically bad side effect. So the default was changed to being Pan. The change was made 7 months ago.

It does seem odd that Shift will toggle Orbit to be Pan, but won’t toggle Pan to be Orbit. It’s always been that way, but now that the default is Pan you don’t have an easy way to toggle, without a mouse wheel.

@trent may have thoughts on that.

Thanks for the explanation; i didn’t think i was doing anything differently. I’m in the film industry, and with the strikes have not been working for a bit, so haven’t stumbled across this change before now.

Unfortunately, I don’t use a wheel mouse; i either use a drawing tablet or a track pad or a regular magic mouse.

Once in the viewport I do find the orbit command under the control+click menu, so I can switch over that way. It’s a little clunky though; if anyone has a solution to hotkey or keystroke+click it I’m all ears - it’s part of my regular workflow, and I’ll switch back and forth between orbiting, panning, zooming a lot when optimizing a view of a model on the page. Going through a menu every time is going to be troublesome.


It’s better to create scenes on sketchup and just select the scene you want to be displayed on the viewport on the sketchup model tray. You’ll save yourself a lot of problems.

I’ll refer you to my earlier comment and not argue whether this is a good idea. I’m a heavy SK/LO user for fifteen years+ in a fast paced professional environment and I have a well developed workflow that responds well to my needs.

1 Like

I modify Viewports all the time, as you say, if you know what you are doing and for the right kind of job it works great. I do however use a scroll wheel mouse which makes it so easy to do, and a pleasure to drive SketchUp too. Perhaps you might try one.

I tried going through the shortcut key options in LayOut Preferences. and it seems to me that the camera tools inside a model window aren’t available for assigning a shortcut key.

If this LO change is really a thing, and I guess it is, I probably should. I usually avoid a mouse because my desk never has enough clear space to drive it around. I may have to change my ways!

I couldn’t find a way into figuring that out; i thought maybe when you’re in LO and click in it’s a default to SK preferences? But my SK hotkeys were solid so that can’t be it. is opening the viewport some sort of partially capable SK emulator, or does it actually run SK within that open window?

I looked through the shortcut list in LayOut preferences both “normally” and when having a SketchUp viewport “open”. The list doesn’t seem to be context sensitive like the one in SketchUp, and I didn’t see any 3D navigation related items there.

I think the defaulting to pan when clicking into viewports has made it much easier for most people. I also dont have this at the back of my head anymore, that I must be careful not to accidentally mess up my viewports. So thats good.

If I messed it up it was usually on plan views that suddenly got orbited by clicking at the wrong thing. Never had that problem with viewports that were perspective to begin with, so if orbit once again became the default for just those viewport we would have the best of both worlds.

If I remember my Layout 22 correctly the viewport would also zoom the scene a bit upon clicking into it , seemed randomly to me, cannot understand why someone would want that to come back.

I agree, it can be irritating to accidentally click through into a viewport and disturb the model somehow. It’s the same as any other number of ways one can accidentally select or click through or drag any number of things, and create something unwanted. Fortunately the Sketchup gods have given us an undo function (I use the standard command-Z) to deal with these sorts of situations.

Keep in mind, readers, there is a checkbox found in preferences/general which will enable/disable model editing for those who don’t see the use for it, and don’t want the possibility to exist.

I do seem to remember the little jump you refer to; i never thought it a problem since I use viewport editing almost exclusively in optimizing perspectival details, so I’m never clicking in unless I want to change the camera angle anyway.

Sure there’s always the undo. It should be a good practise for user interface though, that unexpected things that you did not intend dont happen for no reason. Clicking into a viewport means you want to edit the scope/view. But it does not mean you want random things happen to it before you get around to making your changes. Especially that isometric views are not isometric anymore. So the LO 2023 behaviour must be a good thing. I agree though that the orbit is now a bit too hidden away. I suggested that perspective viewports maybe could default to the orbit tool.

That’s a good suggestion! Here’s hoping they take it.

It looks like an oversight on the new implementation that shift does not work so I will open a bug on this.

When the orbit was the default implementation majority of the time you would experience a “jump” in the viewport that would change your view completely, There were some cases this would not happen but for the most part it would. We found that applying the pan as the default resolved the jump and made the manipulation of the viewport much more manageable. This is experienced best when the middle mouse is available so that context switching is not necessary but we should see if we can fix the shift issue.


1 Like

This topic was automatically closed after 186 days. New replies are no longer allowed.