Layout auto-save not working


Just to confirm for you, as a help, I am on OS X 10.9.5 (Mavericks) and using SketchUp 2014 Pro. I have routinely seen the autosave file in the same folder as the original file and backup file. I cannot test or testify regarding OS X 10.10 (Yosemite) as I have yet to upgrade.

Like Doug suggested, it helps to know your OS
And are you certain Auto-Save is enabled?
Some folks think it’s a bother and turn it off.

just lost a day of work because of layout’s crash. The autosave & backup function were very helpful. if only they actually worked.

1 Like

I usually turn autosave off in all applications. I have tried to develop a tick in my left hand to make it press the ctrl-s (command-s on the Mac) keys often enough. I would hate if an application crashed with me at the end of exploring an unfruitful option and just starting to ctrl-z myself out of it. I like better the option to close the file and reopen it to return to the previous state of the model. Working a full day without saving is rather reckless and will lead to data loss sooner or later, whether autosave is working or not.


1 Like

Doug, you’re not alone. I have the exact same situation and have lost 5 hours’ work today. I have the autosave box checked and even manually changed it to 3 minutes. When i open Layout, there is no list of recovered files. In fact, looking in the folder in which the Layout document originates, there are NO Autosave files of the Layout documents like there are of the Sketchup models. I’m using Windows 7 on a fairly decent 64-bit laptop. There are ‘backup of’ the Layout documents, but as pointed out here, the backups are not Autosaves, and mine was a whole day old. I have put in a support request but at the moment whoever writes this software should just be grateful they’re not in the same postcode since it has just cost me £300 and worse than that, untold stress. I am utterly sick of bugsplats and glitches. Can someone please just make this software that we PAY FOR work?

1 Like

Isn’t the image above the one from Sketchup, not Layout, Geo? The menu is different in Layout.

Hi Marc. I notice your reply is Oct 14 and yet i’ve had the exact same problem today and there are NO Autosave files for Layout (yes, the box is checked). I have no problem with Sketchup, whose Autosave has rescued me from many a bugsplat. But it would be even nicer if it didn’t splat all the time too. Any idea when a fix for this will happen? This happened on Layout 2014 on Windows 7 on a modern 64 bit laptop. As of tomorrow, my licence for 2015 will arrive so i sincerely hope the same issue doesn’t occur there.

1 Like

I too have this same problem. Running Layout 14.1 and SketchUp 2014. Lost a few hours work and no AutoSave files even though that option is checked for every 5 minutes. Soooo… frustrating.
I do think they should at least take the term “Pro” out of SketchUp as it indicates “Professional” which it’s clearly not. This Professional is spending way too much time and money on this buggy software.

I have just had the same problem 2017- and many times in the past - the autosave is just too obscure to find.

You’re not supposed to find the autosave files yourself - LayOut will display any autosave files that it finds in the File->New dialog.

Did you try the autosave test procedure I mentioned in my first post? If it doesn’t work, please let us know what happened.


1 Like

I just had a bug splat, freaked out like @dougjoseph and all the rest of us who found this thread through a frustrated Google search…

Luckily I read @Marc 's thread, and looked in the “New” menu (⌘N). There was a “New”, “Recent”, and “Recover” menu. There was my auto-saved file under “Recover”! Yay! 1 hour recovered! My faith in LO remains generally steady…

Try it! Good Luck!