Layout Auto-save NOT WORKING!


#1

Layout auto-save is not working. I am running Layout Pro 2017 on an older MacBook Pro, OS Yosemite.
Looking back at topics with similar issues I find the comment of SketchUp software engineer Marc Durant in Oct '14:

“We’ve occasionally heard about an issue like this, but it’s been very difficult to pin down exactly what’s happening. I’m particularly baffled by the “recovered” file not showing up the first time you ran LayOut. I’ll have to do some investigation tomorrow - we’ve been doing some work on the auto-save system recently to improve reliability so it’s a good time to research the issue.”

What is the current status here? Why is Layout auto-save not working in my app?
Surely auto-save is an important functionality of a professional product.

Thanks for any help on this


#2

I agree with you that it is important. I’m not seeing this issue with LO2017 at all. It makes me wonder what the auto-save location is set to be on your computer. There have been reports of auto-save not working for SketchUp but it generally turns out that the location is Drop Box or some other not local destination. Is it possible that you aren’t getting auto saved files because LO can’t access the destination?


#3

Thanks Dave,
The Layout file I am working with is in a folder on my Mac desktop. While I do have DropBox in my Finder window I can not see any trace of the file in question within it.

I made a test. I ‘saved as’ a copy of the file into my Documents Folder, made a change, waited till I saw the ‘auto save complete’ prompt, closed without saving and reopened it. The change was not there.
Do you have a sense of what might be causing this?
I appreciate your help.


#4

Hi-

Sorry to hear you’re having issues with auto-save and file reliability. We really really don’t like it when people lose work and it’s a top priority to prevent that from happening.

I see that you’ve had some issues with the auto-save system before… did the previous issues get cleared up, or has this been a consistent problem on your machine?

Old thread:


#5

Thanks Marc, yes it has happened before, but my system doesn’t crash that often and unless I have something going in Layout, I would not notice. Guess I am not sure if autosave has ever worked, really. So, I am running the latest version on Mac Yosemite and my system disk is a bit cluttered with junk from past Macs that were migrated over. Have no idea of the possible ways layout could be going wrong. Any ideas would be appreciated, regards.