Layout 2023

I’m not sure if this is me, my Mac Book Pro or a bug. So Layout 2023 isn’t working for me. So I’ve built my model in SketchUp, I have my scenes. I send to layout. All good so far. I want to present 20 scenes (elevations) of the SketchUp model. Ordinarily, I would simply highlight /right click on mouse/ copy/ paste (or paste to current layer) then change the image to the next scene via the viewport.

However, once I press copy it doesn’t paste. I get nothing.

If I go into an saved file from Layout 2022 and try it on that file, no problem. layout 2023 - Zilch!

Can anyone help?

Can you copy and paste any other element?
(Draw a rectangle, for instance)
Does CMD + C , CMD + V works?

Yes, I can draw a rectangle or a circle and copy paste.

I use sketchup and layout on Mac also and I don’t have that problem with the 2023 version. Does it works if instead of using the contextual menu to copy and paste you use shortcuts Cmnd+C Cmnd+V?
What do you mean changing scene from the viewport? Scenes are changed on the sketchup model tray, you should never get inside the viewport.

It doesn’t work with commands or via the drop down menu.

I change my scenes from this viewport. So, this is after I have either sent my model to Layout or inserted my model directly in layout from layout.

So If it’s not a layout problem could it be a problem with the model itself?

It might be file-related, can you share the LayOut document?
And or the template which you are using?

That’s not a viewport, that’s a tray, at least that’s what is called on windows I don’t know if it has a different name for Mac since it’s a bit different the behavior of “trays”. A viewport on layout is is the window that contains the sketchup model with the properties of the scene created on sketchup.

I’d be happy to. Do you want me to attach it or can I send it to you?

Thanks. I don’t need petty right now, I need a solution.

From your screenshot I would anticipate that your LayOut file is larger than 16 Mb. Upload it to We Transfer or DropBox and share the link.

1 Like

Try selecting a standard template, first.
If copying doesn’t work, it might be your (old?) template.

It’s not petty, it may confuse if the right words or terms aren’t used.

I’ve tried several of the available templates as I did think it could have been by old titleblock, but it’s not working on those either.

It’s 270.7mb. :anguished:

That’s why I asked you to upload it to DropBox or WE Transfer.

I’m also expecting that the size is contributing to your problem with cpying and pasting the viewports. Share the file and let’s see if we can help you get it sorted.

Hi Dave, here is the link.

I’m looking at it now. I see you have two pages with viewports on them showing the same scene but at different scales. Evidently you were able to copy the viewport and paste it once. I’ll dig some more and come back with what I find.

Yes, I duplicated the page once I’d inserted the model.

Thanks DaveR

It looks to be what I was expecting. Your SketchUp file is so huge and detailed that copying and pasting viewports would be very slow. I opened your SketchUp file and did a bit of cleaning. First, I fixed incorrect tag usage. All edges and faces should be untagged. Only groups and components should be given tags.
Screenshot - 7_30_2023 , 7_22_52 PM
Then I purged unused stuff from the model. Looks like you’ve been hoarding a lot of components and materials that you don’t need. They wind up being a huge liability without adding anything useful to your model.
Screenshot - 7_30_2023 , 7_23_43 PM

After purging there are quite a number of excessively large textures in your model which, again, are a liability without being a benefit.

I made those textures a reasonable size. This reduced the file size by about 65.6%.

That cleanup makes copying and pasting viewports in LO faster.

There’s a chair component callled “L1” that has a huge amount of geometry in it. There are other overly detailed (obese) components, too. You could lighten them up to reduce the burden they cause for both your CPU and GPU.

Another thing you might consider is temporarily setting the style’s Face Style to Monochrome while you set up the viewports. Then change the style back to Shaded with Textures before you finish up the document.

Here’s the reduced, LayOut file. As I wrote, the embedded SketchUp file can still use more clean up.

I added a couple of additional pages with viewports and changed their scenes. Open the SketchUp file by right clicking on a viewport so you can work on cleaning it up and when ready, edit the style to show the textures again.

1 Like