Layer Manager loses sight of layers


#1

Just downloaded Make 2015. Opened a new file and set up 3 new layers: Imported a .jpg into one of the layers then saved the file. On re-opening the file all the layers were missing, from the manager, including layer zero, but they are still in the layer display window. I unloaded Sketchup and cleaned the registry (does not uninstall cleanly), then reinstalled which fixed the problem. However this is unsatisfactory in the long term as it keeps occurring and reloading is very time consuming. OS is windows 10 build 10130 but I have the same problem with windows 7. Restting the workspace does not solve the problem.


#2

So you are writing about a layer plugin?


#3

No, there are no active plugins.


#4

What’s the difference between “manager” and “layer display window” then?


#5

The display window is the small box with the down arrow at the side. The manager is the icon that shows multiple sheets of paper stacked. The manager box is completely blank and does not display anything including layer zero, which in theory is a system layer and not removable. Without the manager displaying, you cannot hide a layer or decide which should be the default layer.


#6

I think @asgard1123 means Layers toolbar.


#7

Did you run the installer with elevated privileges ?
Did you set the SketchUp shortcut to “Run this program as an Administrator” ?


#8

no. but I will give it a whirl. I will uninstall and reinstall as before


#9

OK, reinstalled with Run as Administrator. Reloaded the saved file and all appears to be normal. I will carry on and see if it happens again. Thanks.


#10

Your statements give the strong impression you haven’t read this:
Does SketchUp Support Layers? — SketchUp Knowledge Base


#11

Yes have read it. How can you trust a document that discusses layers and then tells you all entities must be on layer 0.
This would imply that sketchup shows layers but does not support them. crazy.

I have reinstalled as administrator but I am still getting this problem


#12

Your screenshots show the same file? If you open the layer window from the toolbar, there are no layers and if you open it from the window menu, they are shown?


#13

Please attach the model so we can see what might be going on.

There are two different ‘Layers’ windows (unfortunately) that do not have the same options.


#14

Yes, same file and yes it does show correctly if you open it from the toolbar.


#15

can’t, deleted the model in a fit of frustration. I will try and recreate it.


#16

Uninstalled, Cleaned the machine then rebooted, then reinstalled as administrator. Seems to have fixed the problem. Missed out the reboot first time round.


#17

Perhaps the document could be worded more clearly; you did not understand what it meant. ComponentInstances and Groups may be associated with other layers to selectively control visibility, but all “primitive geometry entities” (edges, faces, guides) should always be on layer0. Putting primitives on other layers has no effect on their interaction with other geometry and inevitably causes confusing issues with things not being visible when you thought they should.


#18

It would be wise to let go of preconceived notions and accept how it works.
That is, unless you truly enjoy needless frustration.

Layers in SU do not isolate geometry from interaction and unintentional alteration.
A SketchUp layer is merely an assigned visibility attribute … nothing more.

Whether unprotected geometry is visible or not has absolutely no effect upon its innate will to interact with other raw geometry. If you’re seeing this popup it’s an indication bad things are happening behind the curtain.


Geometry is isolated/protected from alteration by progressively building each logical portion of the model and making it into a Group or Component prior to modeling the next portion.



#19

Yes, I understand that layers are for display purposes only and that is very useful. However if entities should be level 0 the program should automatically put them there, otherwise it is simply asking for problems to develop.

These days I kind of expect programs to be intuitive. Maybe I am just getting old and grumpy.


#20

That would be me, explaining layers for the N-th time. :weary:

Over the years it’s become rather painful to watch how many new users come here with layer issues.
And while it’s nice that SU provides the freedom to change the active layer; it would be equally nice if it weren’t so darn easy to assign raw geometry to a layer other than the Default Layer 0 where it belongs.