Ladder Back Chair Leg , geometry erased after File->Save (Validity Check)

I am modeling a Ladder Back Chair found in Dave Richards SU Guide for Woodworkers Advanced Techniques book. I have my parts in place and I am trying to do the joinery in the back legs. I use the Trim and Keep Plugin. I did the joinery related to the back splat and rear rungs first- that went OK.
The problem happens after I do the joinery of side rungs to back leg. When I complete the trim/keep of the 1000x scaled up components, things look fine. I delete the scaled up components and zoom back to the regular size model and things still look fine. A check with Solid Inspector2 and the back leg is still “shiny”. However, when I do a File->Save, some of the geometry of the rear leg is removed. File->Save does a validty check. See attached screenshot. The green section is where face geometry was removed after the File->Save.(validity check)

I attached the .skp file below at the point where the side rungs and back leg are scaled up by 1000x. This is the step right before I would perform the trim and keep between each rung and the rear leg.
I also ran cleanup3 prior to this stage.
Can anyone please
provide some guidance as to what I am doing wrong ?. I am at my wits end.
Thanks.

ladderback chair2_v3.skp (1.2 MB)

If you’re lucky you’ll get an answer from @DaveR himself! (I pinged him for you)

Not sure I’d call it lucky. :smiley:

@zaz1 it sounds like you are ending up with some very tiny edges in the process and SketchUp is trying to “fix” the model. Go to Preferences>General and disable automatic fixing of the model.

Good work on the chair.

Hello Dave,
I’m on a MAC. This automatic fixing of the model selection is not shown. Could not find in other locations.

Are you still using 2021.0 as indicated in your profile?

Dave,
Yes my profile is up to date and I run SU 2021.
I just did a search on “automatic fixing” and noticed another thread that said starting in SU 2021 this feature can not be disabled. Turn off Validation / Auto Repair in 2021
In that thread, @colin of the SU Team, requested to see a file where the automatic validation cuases a problem. Maybe my mention of his name here will get his attention. Otherwise I will post my file as a reply on that thread. I have seen this issue before, and likely only in 2021.
Do you have any other suggestions ?

But is it still 2021.0? Or are you up to date with 2021.1? There was a change at one point where they added the option to disable automatic fixing back in.

The alternative is to use coarser curves so you don’t create the very tiny geometry. If the endpoints are farther apart SketchUp will leave them alone. When they get too close together SketchUp thinks they are supposed to be coincident and deletes one of them resulting in edges and faces disappearing.

1 Like

Yes, 21.0.392.
If 2021.1 has the disable option back, that is motivation to upgrade. I am interested if solves this.
As I said, this has happened before and its very frustrating.

Concerning geometry- I will try coarser curve (lower segment count). I had done a version that was even higher count previously and lowered the follow-me circle to 24s. 12S looked a liitle too coarse, but I will give a try.

You’ve missed a couple of updates, then. Get the latest one from Download All | SketchUp and install it.

Is there a side value you typically use, say 24S ?

It depends on the size of the curve, arc, or circle and how it will be displayed. For a the legs and stretchers on that chair I probably wouldn’t use more than the default 24-segment circle for the Follow Me path and might even reduce that a bit–maybe to 18. For the large curve on the back slats I might go to 36 or 48. A round table top would probably be modeled at 96. Always a multiple of 12 if not a multiple of 6.

Thanks again Dave. I will follow your rules of thumb for segment size. Sometimes I forget and model size gets out of hand. I’ve copied and pasted your last reply into my Folder: Dave’s Words of Wisdom :wink:

3 Likes

A folder the size of a matchbook I’d bet. :smiley:

Did you find the option to disable fixing the model after updating?

1 Like

Hardly. Quite a bit of valuable information over many years. One such nugget is to work in perspective camera mode- which would cleanup the distortion seen in the .skp file I previously downloaded (set in parallel projection mode).

Have not upgraded yet. Thats next. I did however, rework the model using segments in the range of 12-18. This time joinery added cleanly without an issue after file>save.

1 Like

Very nice. Very nice indeed!

Just one (hopefully last) update on this model and the validty check issue. I finally purchased Bool Tools 2 and tried the trim operations which caused the problems I originally described. This worked great, trimming the holes for the rungs into the back leg. It even provided a message and option correcting the small geometry issues which SU flagged at File->Save. I also tried it on the regular size model components and it worked for that case too. And the ability to trim nested components is a another plus. I’ll keep Trim and Keep around too, just in case.
Also expect to try the latest 2021 download version. So far Bool Tools2 looks like it will be very useful.

1 Like

This occasionally happens after using booltools on very complicated, frequently tiny parts, and SU even warns me when this happens. I undo and figure out another way around it.