Knucklehead Operator Focus Solution Needed


#1

I have to be the biggest knucklehead when it comes to keeping focus … on the dialog box instead of my drawing.

Many times I will adjust the “definition” or name of a component in the entity dialog box and then hit “T” or “L” or some other tool shortcut without putting focus back on the drawing first. Now I have just screwed up my component name. Sometimes without even realizing it has happened. Imagine finding a component named “m” in your component list. “What the …!”

I do wish for an “anti-knucklehead” solution to this problem.


#2

How would the (and for that matter any program) know that that the name isn’t allowed to contain any shortcut caracter keys to tools? For that is what you are saying,… typing a name and then T.
End the name typing by hitting [TAB] or clicking somewhere outside the dialog box. That ends SketchUp’s focusing on the field resp, the selection, retaining the name change.


#3

Sorry that I wasn’t clear enough. Of course that is how it is to be done now.

But this is a wish list (feature request) for the masses to dream of solutions that don’t have to use the current paradigm.

How about getting rid of the ■■■■ dialog boxes altogether?

That would do the trick wouldn’t it?


#4

I don’t think so…, if the dialog boxes were docked or part of the main window, input fields would still have key presses until you unfocus them (for example by clicking somewhere else).

Check your operating system settings (probably in Accessibility). There may be an option for “focus mode” or “focus follows mouse”.


#5

Try this yourself. I mean actually try it, because you are probably used to doing it in a way that works and will respond with that procedure.

Add a component. Go to the entity box “definition” field. Type a name for the component.

On my Mac, the “enter” key highlights the whole name in the field. (This is the trap that gets me.)

On my Mac, the “tab” key (as Wo3Dan proposed) does nothing.

Grabbing the mouse and clicking back on the drawing does change the focus as expected.


#6

IMO the Enter key on the numeric keypad ought to “close” the field too, as it does with VCB input. Window focus is one of the aspects in SketchUp that I have always found a bit irritating. The Materials editor and the Edge settings dialog both tend to return the “Invalid length entered” errors unless you perform the exactly right choreography of exiting them. Unlocking the “Preserve aspect ratio” button in the Material editor is also something like a hit-and-miss operation, I usually am finally successful in doing it, but I am not at all clear what I finally did before it didn’t relock itself before I could enter the dimensions in their boxes.

Anssi