Issues with installing "Bitmap to Mesh"

Hey! So I’m having problems installing Bitmap to Mesh by ThomThom on my computer… does anyone else have this problem and/or know how to fix it? It’s rather annoying…

How are you trying to install it?

Extension Warehouse, clicking install/agreeing to let it install, then saving my project and reopening it. But it never shows that it exists.

Two more things you could try:

  • Quit and restart SketchUp. Some extensions aren’t recognized until you do this.
  • Open the extension manager window and make sure the extension is enabled.

Thank you but I have already tried both of these options.
Your advice is appreciated!

OK, so next question: where are you looking for the extension? I don’t use that specific extension, so I don’t know where it adds its items, but they could be on the Tools menu, on the Extensions menu, rarely but possibly on the Draw menu, or on a Tool palette you need to view.

Edit: I installed this extension to answer my own question: it adds an item “Mesh from Heightmap” to the Draw menu.

According to the Warehouse page, the controls are in the Draw menu or in context menus:

Draw » Mesh From Heightmap
Context Menu » Mesh From Heightmap
Context Menu » Mesh From Bitmap

Is this where you are looking?

slbaumgartner: I tried installing it but it keeps acting like I didn’t… I tried clicking ‘Install’ multiple times and yet it will not install. Also, when it said it was installed, I looked in al the sections on the top left part of the screen and in the sections when I right-clicked on the mouse.
Thank you for your help!

TheOnlyAaron: I tried looking there but it is not there. Thank you for your help!

Did you install TT_Lib2? You will have to get that installed before the extension will run.

1 Like

No… that makes a lot of sense now!
Thank you!

When installing extensions, it’s wise to read the page. There’ll be information on where to look for the extension and any required support files.

Ok. I installed TT_Lib2, but the Bitmap to Mesh still isn’t working.

Did you restart SketchUp after installing TT_Lib?

Yes, and it’s still not showing.

Thank you for your help!

Is the TT_Lib2 listed in the Extension Manager ?
Is it activated ??

Yes
Also, an update! Messing around with a 2D graphic, right clicked, and after two months of frustration, bitmap to mesh is finally working! Thank you to everyone and their advice :smile:

Just to save others some time, if you’re not getting the items on the Context Menu, be sure you’ve imported the image into SketchUp as an image, and not as texture.