Is there any other way to install plugin without launching SketchUp?

Hi, I’m facing a problem, that, whenever I launch SketchUp, there’s a pop-up requesting me to install LibFredo6 in order to run Animator.

image

And after I tap on the button which directly bring me to the download page, and then, SketchUp crashed. Now I’d downloaded LibFredo6.rbz, but I couldn’t launch SketchUp, not to say the Extension Manager to install the plugin.

I tried to removed and reinstall SketchUp, still showing the same pop-up and crashed. I really need some guidance here. Thank you!

Read more

RBZ’s are basically a zip file that sketchup can open and install the contents to the correct location. Back in the not so old days we had to do this manually, it’s actually very simple.

I’m assuming you are using windows, but you haven’t put that in your profile, please fix that.
Change the file extension of the downloaded .rbz to .zip. open it and extract the contents, a file and a folder, to somewhere you can find.
Find the correct Plugin folder at
C:\Users\YOURUSERNAME\AppData\Roaming\SketchUp\SketchUp 2024\SketchUp\Plugins
Making sure to input your user name. Assuming C drive.
You may have to change properties to show hidden folders.
Once you have that folder, move or cut and paste the extracted file and folder into it.
Start Sketchup.

NB: You can extract straight into the correct folder.

Thank you for your information. I tried that earlier, exactly the way you mentioned. It’s not working. T.T

Then you missed something in the process.

Presumably you are using Windows. Your profile says ‘2024’ which is not an operating system.

First things first. Close SketchUp, find the installer, probably in your Downloads folder. Right click on it, choose Run as administrator, andthen choose Repair. After it completes, do a cold reboot of your computer. Open SketchUp. If you get the message about LibFredo6 just click No.

Go to Sketchucation and download the latest version of the Sketchucation ExtensionStore and use Install Extension in the Extension Manager to install it. After it is installed, use it to search for and install the latest version of LibFredo6. After it is installed, quit and restart SketchUp.

I tried to repair few times, and cold rebooted. Whether I click “Yes” or “No” still lead to the same result, SketchUp crashed. Toolbar all in grey color, unable to click on it.

Did you install the Sketchucation ExtensionStore and use that to install LibFredo6? Did you use it to install Fredo’s other extensions, too?

There’s clearly an issue with the installation of SketchUp if all toolbars are grayed out. Or there’s a utility window open somewhere. Try Preferences>Workspace>Reset Workspace.

Yes, I click into the hyperlink you shared earlier and downloaded. However it is in rbz format.

Everything was okay as of yesterday (it’s my first day of subscription).

May I know where should I locate this? Preferences>Workspace>Reset Workspace.
Thank you, really appreciate that.

remove the plugin folder (maybe place it on your desktop or something), on the next startup, a fresh one should be created without any of the extra bits you added.

if it fixes the situation, this means your problem is linked to a plugin, probably one of fredo’s.

if that’s the case, you can bring back all the non fredo extensions from your older plugin folder (desktop one) and reinstall fredo’s plugins using sketchucation’s one, starting with the lib.

sounds like something you installed between yesterday and today hit the fan.

top of the screen, window menu. but if it’s all stuck, you won’t access it.

It’s supposed to be in.rbz format!

After you do what @ateliernab directed, allso go to username/AppData/Local/SketchUp/SketchUp 2024/SketchUp and delete the PrivatePreferences.json.

OMG!!! You’re genius. IT WORKS ~ ^.^
Thank you very much!!~

… what part ?

Thank you @DaveR. Thank you for being so patient and find solutions with me, really appreciate it. ^.^

After you do what @ateliernab directed, allso go to username/AppData/Local/SketchUp/SketchUp 2024/SketchUp and delete the PrivatePreferences.json.
[/quote]
What is the purpose of this document? What will happen if it is not deleted?

… what part ?
[/quote]

To remove the entire plugin folder.

It is the file that records the preferences you’ve established.

Maybe nothing. If you do delete it, it will be rewritten when you next open SketchUp. I suggested deleting it because it could be that you have some bad information saved in it. Deleting it and letting SketchUp remake it can clear up possible problems.

Got it! Thanks for sharing~