Is SU code the bottleneck or my PC?

On a regular basis I’ll perform an operation in SU just to sit there and watch SU move to “Not Responding” until the operation is performed. In Task Manager I always look to see if there is some hardware component being maxed out. CPU (i9 @ 5ghz) is never more than 20% and the GPU (GTX 3090 24gb) is never past single digit percentages.

What’s throttling the operation at that point if not the hardware?

Also, is there any setting I may be missing that could allow SU to take full advantage of the PC resources?

SketchUp will only use a single core of your CPU. Your CPU’s speed has a lot to do with it.

About to say the obvious here, but that seems like a massive limitation for a 3D program. Is that just some legacy codebase thing?

No, it’s inherent in all 3D drawing programs - all operations happen in a single thread.

1 Like

You clearly have a very powerful machine! Top of the line hardware. I’m curious what types of operations are holding up your computer, and how complex your models are. It might reveal something that can be addressed.

There’s no particular operation that I can think of. Certainly when I’m working with larger models (100mb+) but again, it appears you really can’t “throw more hardware at SU” if it’s always going to be rate limited by a single thread on a CPU.

100MB is pretty big, but file size isn’t really the best indicator for model complexity. It’s usually finely detailed models with many thousands or even millions of edges that start to tax sketchup more than anything else. You might start there for ways to optimize your workflow.

All programs of this type are limited to one thread, this includes Autocad and others.

If you don’t mind indulging me, what’s the technical issue that prevents these types of programs from using all the threads?

Check this thread:


@MikeWayzovski this was incredibly helpful thank you so much. So with my 8 cores, it sounds like at most I’m going to max one @ 5ghz (OC’d) and the rest are free to go run some parallel SU instances.

Most of my models are around 300mb in SU2021 (thats about 500 in pre 2021 money) and I have no problems, this is probably because my geometry is relatively simple but there’s a lot of it’s plus of course the textures which I expect account for a lot of the mb’s.
This pano tour has panos from 2 models; one for the exterior/site and one for the interior. The site model is 185mb and the interior is 333mb. Any complex models such as the beds are proxied in during the rendering initialisation.

1 Like

One of the biggest problems I’ve seen is the newer versions of SU running on Windows 10 have some serious lag issues once the model gets to a certain size. I still use SU8 and Windows 7 for this reason. Newer versions of SU are trying to reference all kinds of nonsensical things just like Layout. Also, Windows 10 somehow compounds this by treating your PC like a phone. When I’m dealing with lag from a large model, I make sure to collapse my Entity Info, Layers, and Materials windows. This keeps SU from referencing quite so many things while you’re doing an operation. It also helps to turn off any unnecessary layers, or to make a layer that is just for complex geometry so that it can be turned off while working on other things.
I was researching the Windows 10 issue a while back, and at the time nobody had found a true cause or any solution. I used a Windows 10 machine at work for a few months, and I noticed that no matter how fast the hardware, this lag issue was still a big problem (less so on SU8, but still no fun). Keeping complexity out of the model helps the most. And always make sure that OpenGL settings are correct (use fast feedback and never use maximum texture size).
But no matter how bloated Trimble makes newer versions of SU or how awful Windows 10 is, I’ve never see a program as fast as Sketchup. I also use AutoCAD here and there… and a model that is 1/10th as complex as a large SU model will lag 10 times worse… and god forbid you turn faces on in AutoCAD… might as well go have a smoke if you just orbit a little.

Regularly traced to poor graphic drivers pushed by windows updates.