iPad with Apple pen

Several things about SketchUp that upset me. I used this product years ago but the version became unsupported. I purchased it again as I wanted to use my iPad BUT found out that it works only with Apple pen 2. My iPad only takes Apple pen 1. Not to happy with this product. I have used Shapre3D just fine but thought that SketchUp would better suit my need.
Disappointed much. I feel that I have been sold an inferior product.
Also went to email but only to find out I need a Google account to email. What’s up with that. ???

1 Like

I’m sorry you feel that way.

The reason the app only takes the pen 2 is because that is the level of performance the newer iPads are operating on. I myself have two iPads that only take the pencil One, and neither of them has the ability to handle SketchUp. The program (if it loads at all) is sluggish and downright glitchy. But that has happened in ALL of the apps that I live in… Callipeg is downright unusable, the difference between the two iPads and pencils is like using two different programs. This is the way of technology. It gets better and our systems become outdated. There are many users on Windows computers dealing with outdated/unsupported graphics cards who also have issues.

In all honesty, being as new as it is, SketchUp go being made to ideally work with the most current technology makes the most sense. And the iPads that use the second pencil have been around for more than 5 years … Which is an eternity in technological age.

I highly recommend SketchUp on iPad, but not on an older system.

I hear you but there was no information on this prior to purchasing the program Not cool in the marketing department. Shapre3D worked well on my iPad with and pen 1

Hmm, I have a plain iPad G6 and a first gen Apple Pencil and I’ve been using the SketchUp iPad app for months. It just doesn’t have the double tap feature of 2nd Gen Apple Pencil.

1 Like

I have an iPad Air (3rd Gen) and Pan 1. running OS 15.6.1 Not working. Yours must be a later generation

Ok, don’t know then. I knew the critical thing was the most current version of iOS, but if it can run it, then I don’t know why it wouldn’t work.

Hi @Doug48 thank you for your post, and welcome to the forums…
I’m sorry that your experience with SU for iPad has been kind of a bummer thus far.
To reiterate, and help clarify a couple of the responses offered up thus far:

  1. @RTCool is correct in that SU for iPad supports both the 1st and 2nd generation Apple pencils. He is also correct that 2nd gen Apple Pencil is ‘recommended’ because our app supports the additional capabilities that are offered by the 2nd gen pencil.
  2. We recommend that users remain up to date on the latest version of iPadOS (which, at the time of this writing is 15.6.1).
  3. @Danimaupin is also correct in pointing out that mileage will most certainly vary with respect to performance based on the hardware specs for your specific iPad. SketchUp is a memory intensive application and may not fare particularly well on older, less capable devices.

That all being said, we have seen other instances of customers who have emailed in to our support channel to report cases of SketchUp not working properly, claiming that they were unable to use the app with their 1st gen pencil. At least 2 that I”m aware of them took their iPad and Pencil into an Apple Store and reported back that it was actually the pencil that was malfunctioning, and that after testing a new pencil, the app worked as expected.

1 Like

If you are using an original pencil, you may have a firmware update to do for it - You do that by plugging it into the i.Pad and leaving it there for a few minutes.

The latest version was 2.61

Yes, another great suggestion. Thanks, @Elmtec-Adam!