Invalid selection. There are no non-vertical faces to stamp

Hi Community: I’m placing multiple buildings on my downloaded Google Earth Topography and all has been working perfectly, until now. My process: 1) I copy a clean and solid 3D footprint from one master design file, 2) past in place the footprint to the topo file above the surface, 3) click stamp, set the transition distance, etc… and everything has worked for the previous 13 footprints. Now, I’m suddenly getting this “non-vertical surface” warning. I’ve checked the axis, made sure Z is up, X&Y aligned, no hidden geometry is found, etc. I then took an adjacent building footprint and everything worked normally again. Any suggestions? Thanks in advance.

It would be helpful if you would share your SketchUp file so we can see what you are working with.

How did you get Google Earth topography into SketchUp? Google hasn’t allowed that for about 3 years.

Hi Dave.

Thanks for getting back to me. I drew the building again and took a new footprint and everything worked fine. I then placed the remaining buildings. Then I encountered a completely new situation.

I took one of the on-site roads and one on-site parking lot from the same master drawing and draped them onto my topo model and they overlapped my buildings, which of course they don’t do on my master drawing. So now I’m totally baffled and burnt out. :joy:

So how do you suggest I send files to you? BTW, I’m in the Southeast Asia time zone (+12-15 hours from US) so the message exchange will be a bit off kilter.

Joseph

Perhaps it had something to do with the selection the first time.

How did you ensure proper placement of the elements from the “master” to the terrain?

Files can be uploaded here on the forum. If they are too large to upload directly, you can upload to Drop Box and share the link.

OK, will look into that tomorrow morning. We have notoriously inadequate WiFi here and the files are large so I’ll see what I can do.

Joseph

You’re far better off using Drape from the sandbox tools, rather than stamp.

Here’s the Dropbox link: https://www.dropbox.com/sh/fwryzdqf5ygei8d/AADuL6hsGq_l4_-omfZ1KGmpa?dl=0

Hi Dave: Having any luck with the files?