Intersect with model quirk


#1

Hello, noob here to Sketchup. Long story short, my girlfriend’s son has an assignment in Sketchup that has the engineer stumped, and I even had some CAD experience in college. Poor guy is in the 8th grade and we’re all stumped!

Assignment is to draw a box, and ident a spherical divot in two faces. Box is drawn, spheres are drawn. I figured out how to locate the center of the sphere in the center of the side of the box by drawing a line between the endpoints with the x-ray view turned on, and using the center of the line as the move point.

If I select the sphere, select the box, and intersect with model, it draws the line of intersection OK, but then I can’t select the sphere itself to delete it, they become one entity. Saw an example video similar to this, but it’s just not working. If I leave it in this state, I can use the erase tool to delete the parts of the sphere, but the box stays the same.

If it’s a clue, when I do the intersection, the spheres get those lines turned on (same as view hidden geometry), and when I tried to erase them with the erase tool, they erased in fragments.


#2

Could you please upload the SKP file so we can see exactly what you’ve got going on?


#3

Are you using groups or components in your model? If so that may be behind what you are getting (not a bug, just understanding how things work in SU).

But, as Dave wrote, unless we see the model we are just guessing based on experience.


#4

Thanks, I can look into groups and components. I’ll have to upload it when I get home tonight.


#5

Jackson3.skp (206.7 KB)
Here it is. Looks like they are neither groups or components. I tried making them as such, but despite letting me select them individually after the intersection and deleting the sphere, the cube stayed the same. I did move the one cube off the cube first.


#7

I went ahead and made some screen shots. There are a couple of things going on that will cause issues. First, the sphere is shoved into the cube a wee bit too far. You can see this with hidden geometry turned on and X-ray looking straight in.

Due to the small size–the cube is 1" on a side–there would be gaps just inside the surface of the sphere because SketchUp doesn’t do really small faces.

Move the sphere out a little so those hidden edges at the equator are on the surface of the sphere.

The next thing is there are lots of internal faces. It’s as if the sphere was an orange.


Those faces will create a mess during the Intersect operation.

After cleaning up those faces you can see the sphere is much cleaner.

And with those fixes,Select the sphere and the face it’s in, right click, run Intersect Faces>With Selection and then select and delete the portion of the sphere outside the cube and the skin over the dimple.


#8

Thank you! I’m not sure how it made all those faces inside, must have done something tragically wrong when I made the first sphere and it carried into the next, I don’t know where those “orange slices” came from. I started over, and I think I’m able to do it now. It intersects and I can select the protruding hemisphere. I got a little confused since it left the face of the cube covering the divot, but once I removed the face I can see the divot now. Hopefully we can talk him through it now! Many thanks!


#9

It might be useful to think of it this way. The intersection operation not only splits the sphere into two hemispheres, it also splits the face of the cube into an inner and outer region. In the same way you have to delete one hemisphere in the cleanup process, you also have to delete the inner region of the square face. The dimple is thus the remaining hemisphere. So although it looks like the sphere was pushed into the cube, it’s not really that at all.