Intersect Faces and other Menu Items Greyed Out

I’m sorry for responding. In the context of the thread, it seems clear to me that he meant temporarily disabling extensions to determine if an extension is responsible and which one.

Replying to the greyed out problem I’m having:

Thanks for the tip on the sketchucation plugin for updating, that actually would save me a lot of time and even though I have it I never use it, purely for updating purposes though is something I never thought of, I don’t really like using it to find new plugins but the updating thing sounds good. I’ll try and make sure all of my stuff is updated and during that period where eveyrthing is totally up to date I’ll try and see if the problem goes away and if it does I’ll probably make a thread and report about it.

Thanks and if you find anything else out in the mean time would love to know as I’m growing quite tired of having two sketchup windows open all the time.

Fair enough, I could have easily assumed that as well, I’m just going off of literally what the guy said is all. Cheers.

I haven’t seen the grayed out menu items referred to here since I installed the update to LibFredo6 that Fredo released back in November of 2019. I haven’t seen any other reports of this from anyone who had updated, either.

You need to be using it to install extensions from Sketchucation to get it to keep track of them and let you know there are extensions to update. Personally I find it much easier to use it for searching for and installing extensions than searching for, downloading and then manually installing them through Extension Manager. Using it also means that I can quickly and easily install the same extensions when I move to a new SketchUp version or to another computer.

I didn’t know that, I don’t know much about it. I just looked at the updates area of it and that’s aweome so it definitely will help me out. I appreciate it, thank you!

Hey @Fredo6 this seems to be back in the latest version of 2021 and Libfredo11.9b.
Only popped up again after I updated 2021, I even repaired it to check and updated Libfredo. Still happening, any ideas if it might be from your end?

Do you have LOTT installed

Yes, I do. I had it disabled before but it started itself up again when I updated 2021.
I disabled it just before I posted here, and haven’t been working again so can’t say if disabling it stopped the issue.

I’ve been seeing this again, too, since 2021.1.1 but I have not yet installed LOTT. Disabling LibFredo6 seems to have cleared it up. I suspect it’s a change on the Sketchup side that caused it. When I first started seeing it LibFredo6 hadn’t been updated for some time.

Guys, you lost me…what is LOTT?

Lord of the Toolbars.

A new extension from Fredo6.

Ah! Thanks, I forgot about that as I haven’t tried it yet.

1 Like

I am lucky that I can reproduce the graying-out after about 30 right-clicks on an object.

This seems to be related to SU2021.1 (Build 21.1.299). I don’t have it on SU2020 with the same exact list of plugins.

It seems also to be related to LibFredo6 or one of my plugins, because I don’t get the problem if I disabled all my plugins (after 60 right-clicks).

If a user has an older build of SU2021 and LibFredo6, then could you try the 30 right-clicks to see if contextual menu becomes grayed out.

It’s encouraging that you can reproduce it.

I think if it would have happened in 2020 or the older builds of 2021, I would have certainly seen it but I didn’t.

Do you remember when the latest SU2021.1 (Build 21.1.299) build was published ?

It was published around 8 June. At least there’s a post on the 8th from Mark regarding it.

Update: I disabled LibFredo6 and all my plugins, and I still get the gray-out syndrom after 70 right-clicks on an object (doing nothing else after starting Sketchup)

If anyone has the time, could s/he try to reproduce it.

New Update: I disabled ALL plugins in SU2021.1. I stll get the gray-out syndrom after 127 right-clicks.

It seems that the problem is in Sketchup 2021.1. Simply, the number of plugins loaded, among which mine, would make the gray-out appear quicker because it looks to be be senseitive to the number of commands loaded from plugins (and my plugins have many).


New Update:

  • I can reproduce it systematically on SU2021.1 WITHOUT any plugin loaded at around 130 right-clicks
  • in SU2020, with ALL plugins loaded, mine and many others, I DON’T get a gray-out even after 450 right-clicks.

So, definitely a problem with SU2021.1.


Thank you Fredo6!