Install of 2020.1 fails on macOS 10.15.4

I selected from "check for updates”, it took me to the Trimble update page where I selected the Mac 64-bit 2020.1 version of update which downloaded successfully.

I clicked on the installer and it opened up (displaying two icons in the dock [one labeled as "Install SetUp Pro 2020-1”, the other as “Java”] By the way I have Java 8 update 251 installed. The the process runs until this dialog shows the installing process has hung in this state for as long as I care to wait …
[Screen Shot 2020-05-01 SketchUp Pro 2020 installing… and hung]

1 Like

Your screenshot didn’t make it. Please try again and wait longer until it completes the upload.

skip 2020. it has a lot of bugs and no ones working on it.

Where on earth did you get either of those claims?

You may have missed one step in what happened. Were you asked to close either SketchUp or LayOut? If you were, when you proceed it does get stuck at 5%. The issue is mentioned in the release notes, though it doesn’t tell you to try again. If you try again it should get to 100% fairly quickly.

The two icons in the Dock is an oddity, but is just how the installer software does things. It’s also possible to have the installer be in the background, if one of the Java icons is bouncing for a long time, click on it to bring the installer forward.

Though one notices from your profile that you seem to be using it…

Anyway, you would find lots of posts about it on this forum if it were true.

I was, stopped using 2020v back in feb coz its just too much. Becoming too Counter productive. Went back to 2019v

This May though i reinstalled 2020v but still same issues.

A few bugs to note:
Graphic artifacts in Layout
Performance issues in Layout, sometimes sketchup
Workspace crash - I’ve posted this before.

Look through the forums, they’re mostly Mac related but not specific to any os or hardware.
I’ve the same bugs/errors in my 5yrs old mac running its Native OS and on my 16” mAcbook pro running catalina.

Just look thro the forum, they’re mostly mac related.
So if you’re using pc it wont affect you.

I stopped using 2020v in Feb and switched back to 2019v

This May i reinstalled the 2020v and its still has the same bugs. So guess no ones worked on em yet.

Same problem here. Problem has to do with MacOs Catalina (10.15) and Java. There are more restrictions on running software that can;t be scanned on Malware. I have installed the latest Java (JDK 14). Which is working ok. But in this update there is an own Java used. This java is not accepted bij MacOS. It seems this is a bug that only can be fixed by Sketchup.

What happens if you download this one (the latest)
Then, override the warning: (Open toch-en):

The Java update works after granting the permission. But the Install of Sketchup 2020.1 still fails

I don’t think updating the Java on your system will help. The SketchUp installer has its own Java bundled inside the installer which is version “11.0.6” 2020-01-14.

Would I be correct in saying then, that the newest update will not install on Macs?


No. It installed fine on my 16" MBP running Catalina 10.15.4.

There appears to be some sort of conflict with certain versions of Java. Straight from Apple, macOS does not include Java (Steve Jobs hated it!). So unless you installed it yourself or it came bundled with another app, you should not have Java.


I got 2020.1 installed on my Mac!

I first signed in as an administrative user (I usually run as a ‘standard user’ and rely on the macOS installers to ask for administrative privilege at some point.

Anyway, 1st time I tried just double clicking the installer it seemed to hand with just a bouncing SketchUp single icon (not the two I was getting previously). I used the the mac’s activity monitor to kill it.
I then started up my old SketchUp but didn’t do anything with it. Then I started the 2020.1 installer again. This time it ran to success!
I note that the installer seems to 1st expand an archive using 7-zip. I’m wondering if 7-zip also needs premission to store in a folder by the Mac OS system that is automatically granted by running as an ‘admin. level’ user. Permission that a macOS installed first asks for. Anyway. I returned to re-login to my ‘standard user’ and was able to launch SketchUp 2020.1 there too.

1 Like

Thank you Steve

That’s good news as my new 16” MacBook Pro should be arriving next week.

Kind regards


Can you say whether being admin made a difference in the end? There’s an odd case with Windows where being admin failed but not being admin worked.

A lot of users have one account on their machines which by default has admin. privileges.
My machine has two, one is the admin account, the other is the one I usually install and run my applications in. In macOS the installer always takes care of running as an admin. privileged user when doing an install.
I have both a windows workstation and a Mac (rMBP) and I have seen in the past (more so a few years ago then recently) that windows sometimes assume you already at admin. privilege level when the install began. Windows added the dialog box to ask for an admin. name and password.
Now in macOS 10.15.4 we are really getting locked down on things. Apps need to ask for user permission to access devices, the full file system, and more.
SketchUp Pro changed there install process too this time.
They say you should unzip the download file and then run the installer.
However, macOS automatically unzips the download file and hands it to the user ready to run.
Thus the first step is already done on the macOS when the user gets the file.
Since 7-Zip now runs I become confused because it is already unzipped or is it? I did see the notice that 7-zip was running but was this the second time it ran?
I think the SketchUP people need to the a closer look at what happens on Macs.
I am happy that I was finally able to get it to run.

Download never automatically unzips a file on my Mac. I have to click it to make it unzip. Perhaps 7-Zip added a trap that does this for you?

In Catalina it is standard that macOS blocks access to various resources until the user explicitly grants permission. There must be a way to detect this during installation, as I have had other installers notify me to adjust privacy settings during the install process. SketchUp needs to follow suit!

The unzipping is a browser thing. Safari unzips for me, Chrome doesn’t.