Incredible Lag when triple click selection. Skp 2018

lag
poor-performance

#1

When I am in a medium sized model that ran perfectly fine in sketchup 2017, I cannot triple click geometry. The program locks up for a few seconds and the attempted selection remains un-selected.

Overall performance took a big hit going from 2017 to 2018 for me. Updated drivers (quadro k2200) and everything. Its seems that if I have any models more than 20 mb I see huge performance issues even though these models ran perfectly fine in Skp 2017 pro with loads of plugins and rendering extensions.


#2

there were already issuse w/ the OGL support of Quadro drivers, try if disabling “Window > Preferences > OpenGL > Fast Feedback” helps.

If nothing works buy you a GeForce GTX 1050Ti or GTX 1060 which are btw much faster than the K2200… besides other CAx applications do require a Quadro of course. Check space in case and wattage of PSU befrore doing that.


#3

Thanks for answering.

I had already done this with slight improvement before my original post.
Other identical hardware PC’s in the office see no issues with exact same model. My PC runs correctly but there must be some sort of programming setting in the background that I cannot rectify.

Maybe I need to clear some registry values associated with sketchup that do not change with a fresh reinstall.


#4

When you installed SketchUp, did you right click on the installer and select Run as administrator?


#5

No, but that’s like the new “did you turn it off and turn it on again”

I guess I should try that. Do you know anything about doing this solving issues?


#6

:slight_smile:

There have been all sorts of odd issues reported over the last few years that all seem to stem from incorrect installation on Win 10 machines. Repairing the installation by using Run as administrator from the context menu has fixed them.

Use your normal log in. Do not log in as the system administrator. Find the installer, right click on it. Select Run as administrator and when prompted, select the Repair option.


#7

■■■■, already clicked uninstall, reinstalling now.


#8

Oops! Well, let’s see how this goes. Getting SketchUp 2018 installed correctly is a good idea no matter what.

Due to security measures that Microsoft as put in place it’s a good idea to install any program with Run as administrator now. It’s not just limited to SketchUp. I’ve seen issues with several other programs that weren’t installed that way.

Also see this post: Select Tool lag issue on Windows 10


#9

Did not correct my issues unfortunately. I am using windows 7. At this point I want to just get my 2017 license reactivated, I don’t understand why they would disable the use of older versions after a period of time.


#10

You would need to contact Customer Support for that.


#11

check the used anti-aliasing on the OGL preferences too resp. don’t use more than 4x aa which can hardly be seen anyhow.

And check there too that SU is running on the Quadro and not on a possibly integrated intel HD by clicking on “Graphics Card Details”:

Don’t fiddle aroung w/ registry settings until you know what you’re doin’… SU 2018 saves non-OS related settings in JSON files anyhow:

• User: “C:\Users[user name]\AppData\Local\SketchUp\SketchUp 2018\SketchUp\PrivatePreferences.json”
• all: “C:\Users[user name]\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp\SharedPreferences.json”


#12

Thanks but I already made sure everything was at lowest possible setting. This issue does not seem to be related to the graphics card and the machine is dual xeon e5-2630 v3. I have contacted technical support because we do have many user license hopefully that will prompt them to reply quickly.


#13

if only several models affected you might want try to purge unused elements to reduce the entity count at “Window > Model Info > Statisitics” (w/ “Entire model” selected):


#14

If your company has a network license, all users must use the same version. If any user activates a new version, a 60 days grace period will follow. After that period, all users must ‘play along’. If the activations of the new versions were removed before the ending of the grace period, everything stays the same.

A standalone license is perpetual, which means you can use it as long as the OS lets you. If you have a maintenance, you’ll receive a new serial and code for the new version, which you can install besides the old(er) version.

So you can have multple version of SketchUp installed on your system.

You can use the trial period of 30 days to decide wether you ‘play along’ with the new version or not, you don’t have to activate it right away!

If you do decide to activate the new version, the old version get the status of ‘on hold’ which means you can not install that version on another machine anymore, since you decided to trade the new version for the old.

Sometimes you skip a version, eg you have version 2016 and a maintenance contract and received the serial and codes for version 2017 and 2018, but never activated the 2017 version. In this situation, you can not install and activat the skipped version 2017, only the latest!