"incompatible Open GL version"


#1

I have Sketchup 2016 and it works and runs fine but after “upgrading” to 2018 it tells me that I have an incompatible Open GL version and Sketchup can not run. Now I do not have either 2016 or 2018 and I am stuck in a limbo. I tried running Sketchup as administrator, tried uninstalling and reinstalling Sketchup but the error persists! I do not know what an “Open GL” is or how to find a compatible version. There seems to be nothing bundled with Sketchup 2018


#2

Did you uninstall SketchUp 2016? There’s no need to do that normally since each version installs separately.

OpenGL is a graphics thing. If your graphics card is old it may not be able to support SketchUp 2018’s requirements but you can check with the maker of the graphics card and see if there’s a driver update. If there is, install it. Perhaps that’ll fix you up.

In SketchUp 2016 there was the option to disable Hardware Acceleration which dumped rendering duties to the CPU. It provided an option for those who had graphics cards that weren’t up to the task. That’s not available in SU2018.


#4

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.