Incompatibility with Windows PC with an RX580 Graphics Card


#1

I just purchased a new PC with Windows 10, and i5 processor, 8 GB RAM and 1 TB HDD. It also features a RX580 graphics card which should be around the processing power of a GTX 1060.

However, when I attempt to use SketchUp Pro 2018, every single thing I do is met with a second or more delay.

When I run the Checkup program, I get this result:

Error: Your “Radeon RX 580 Series” graphics card has 1 MB of graphics card memory. SketchUp requires a graphics card that has 256 MB or more of memory. Note: if you think this error is incorrect, see Help > Documentation.
Error: Tests that exercise your graphics card’s capabilities have failed.

I’ve updated the driver. It’s the only graphic device listed in the Device Manager. I’m not sure what to do next.


#2

That is an error with the Windows reporting tool the Checkup program is using in the background, so that doesn’t mean anything.

Where did you get the upgraded driver? If you got it from your computer manufacturer you might try one directly from AMD. AMD graphics cards have a flaky history of OpenGL support but in my experience drivers less than about 6 months old have worked. Computer manufacturers often do not upgrade their drivers as often as AMD. The latest driver from AMD is 6 days old (released on the 23th of March.


#3

I have the same problem with a new System, Windows 10 64-bit, 8 GB RAM, 2 TB HDD, MSI Radeon RX 580 with the newest AMD graphics drivers and new BIOS version.

SketchUp 2018 Pro does not work with hardware acceleration.

I have got the same message from the Checkup program.

I am running several other programs on this machine, Abvent twinmotion V2 (runs nearly 100% over GPU), Adobe Photoshop runs with hardware acceleration, Google Chrome uses hardware acceleration.

So I think the problem is definitely not the GPU or the PC, the problem comes only from SketchUp 2018.


#4

The Checkup utility will write a .sulog zipfile to the Desktop with information from the tests.
It helps helpers help you if you add this zip log to your original post.

This is a common issue with Windows 10 recent updates.

There are several very long threads on this in the Technical Problems > SketchUp category.

…and others …
https://forums.sketchup.com/search?q=selection%20slow%20category%3A28


There was a fix released for SketchUp 2018 Pro …


#5

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.