In 3D warehouse: I can't enable comments

In my model Home Theater Speaker Set and several others I noticed comments are disabled. When I try to enable after clicking on save I get the response “Something went wrong while saving changes to your model. Please try again.”

How to fix please

There were some recent changes made to the 3D Warehouse. I wonder if anything changed regarding comments and Make users. Perhaps @TheGuz has some info.

1 Like

Thanks for the reply but no buz from The Guz may b cuz possibly not checking messages? I don’t think affects all Makers as doesn’t affect all models. Went thru about half and found 9 (out of maybe 60 total) of which 2 was able to enable. Have found work around for others but is quite some effort

Looks like the issue has been mostly resolved. Just a few remain needing fix which I can take care of. Thanks.

Thread can be closed.

1 Like

On most recent upload had this same problem occur. Did some experimenting and may have found the cause of issue. It might be considered as part of comma-delimiting. If “#word,” (notice the comma position) is keyed in SU won’t save but if “#word ,” (space prior to comma) SU will save.

A totally separate issue is in regards to comments being disabled or not. During initial upload comments are enabled by default but during update comments are disabled. The location of whether comments are on or off during update are located at bottom of page and may have scrolled off the screen and one is unaware comments are disabled. Might be a good idea to locate switches up closer to save button so it can always be seen. Just a reasonable thought.

1 Like

A couple hours later and found that the period seems to cause the same problem, ex. “#two_words.” won’t save but #two_words ." will save.

1 Like

Hey orbsphere! Thank you for all the testing and apologies that I’m late to the party. I’ll raise these two issues with the team and see if we can recreate it and find a solution.

Ok. I was able to recreate the punctuation after a hashtag problem and submitted for a fix.
I made some changes (updated description, added a URL, change the thumbnail) but I can still comment and the “Disable Comments” toggle was still off (allowing comments). I was able to leave comments after each change. Is there a specific change being made that toggles that to “on”?

Hey Guz, No problem, I bet ur just being stylishly late to the party LOL I haven’t been to the Forum lately myself to check for messages so am slow now getting back to you.

Nothing else specific comes to mind. I do recall in the past that both switches for privacy and comments were grayed out when uploading a new model but sometimes (I guess depending on where one updates from) I noticed that the comments were already blue or had already been disabled but not by me (I wasn’t aware of which color it should be to have them on). So to my simple way of thinking it seems kind of confusing.

Riddle me this Guz-man LOL If the switches are both gray, the privacy is turned off but enables leaving comments turned on. Which means to disable comments the switch needs to be blue to turn them off. But gray indicates off for privacy, so does the privacy now need to be turned to blue to be on? Rinse and repeat.

Before I learned the secret to updating a model I hunted all over for an update button. Maybe an upload/update button would help but maybe I’m the only dodo LOL

I’ve just learned that both switches have to be grayed out to function properly. Perhaps a different choice of words but I’m at a loss for suggestions without having the switches right in front of me.

Thanks for your attention, Justin

OK so I just made an attempt to update a model. To do so I generally always go in thru My Public Page and select the model to up date and select the 3 vert dots (an ellipsis?) which gives me the option to “Edit Model”. I select that and the “Private Model” is grayed out but the “Disable Comments” is blue (that appears to be the default setting for entering that page using that method). So if one has a maxed out description that function switch is scrolled off the bottom of screen and may not be seen.

I guess a person might notice that the comments have been disabled and can go back to correct the setting. But I’ve noticed a lot of people don’t proofread or go back to see how things might appear to another person when viewing. And then with that “# comma and/or period” item I pointed out if one wasn’t aware of that issue there was no way to get Comments Enabled once they were Disabled.

I understand you’ve looked into the # issue put it appears that at least on one path into editing a model the page has been set to Disable Comments by default. So the ball is in your court to track it down. I can’t do much from my side. I know you’re working on it so good luck in the search for the culprit.