Imported model (any format) has huge, unremovable extra surface

styles
import
edges
hidden

#1

I downloaded a model of an airco, stripped out the wall it’s attached to (select -> delete key), and saved it as a new file, to have a clean model I can import. The problem is that when I import it into my main composition, that old wall is still there, although invisible and now inseparable from the main model (I can’t delete it without deleting the airco).

Any help finding out why it won’t stay gone/how to get rid of it would be much appreciated.
Cheers


#2

Have you deleted the complete wall or only the face and the edges are still there? Or have you changed the axis so that you get this big bounding box? You should upload the changed model and not only the original model link and we will be able to see the reason…


#3

I (and others) would like to go for the appreciation but then we need the model, don’t we?
Please upload the skp, Just a screenshot won’t do.


#4

Yeah sorry, I’m limited in the links I can post and I figured listing the exact steps I took would clear it up… Anyway, here’s the edited model: https://dl.dropboxusercontent.com/u/3357590/airco.skp

As far as I can tell, the wall is gone. There’s nothing left I can select or anything.


#5

It doesn’t take much to make that sort of thing happen. Here, I’ve sort of duplicated it.

I did that by putting a little short line segment up in space.

You might have a look up in that upper right corner for a similar segment. Delete it while the component is open for editing and all should be fine. Turn on Hidden Geometry first because the segment could be hidden.


#6

I selected almost my entire screen (the size of the import is definitely within my selection) and hit delete (with hidden geometry revealed), and did the same with the drag-delete tool, but there was nothing there and the same thing still happens :confused:


#7

I dunno what was going wrong, but I fixed it by cleanly selecting the airco, copy-pasting it into a new composition and saving that :slight_smile: Thanks guys


#8

Don’t work for me…


#9

[quote=“Marnes, post:7, topic:16164”]
I dunno what was going wrong,
[/quote] when opened the model had all the edges turned ‘off’, turning them ‘on’ makes selection of the face edges more obvious…

I’m guessing you where selecting the face but not the hidden edges for deletion, double clicking the face would also extend the selection to it’s edges…

john


#10

I did say to turn on Hidden Geometry but evidently that got missed or you would have found the edges that need deletion.


#11

I did turn on hidden geometry but that didn’t reveal anything. I turned it on and selected a wide area that would definitely have gotten those edges and hit delete even without the selection revealing any lingering edges. Jesus, I can read, you know. I dunno why those edges were being such a pain and wouldn’t show up.


#12

My mistake. It was a style setting as John found. Edges turned off in your style setting. That’s alright for display purposes but not so good for drawing.


#13

This seems to have been it indeed: after making sure edges were displayed, they did show after deleting the surface. Thanks.