Import AutoCAD 3D Civil Contours to SketchUp 2019

Hi All,

When I look for this topic, most of what I’ve found is from 2015 and the links don’t work anymore.

I’ve been following Daniel Tal’s prep for exporting CAD files, and I’ve done the appropriate work of:
exploding blocks and objects
purging
auditing
checking file units match
saving down to an earlier version of AutoCAD

Per Daniel Tal’s instructions I have tried writing the lines to a block and importing, and also tried not creating a block and importing. When I import the drawing into SketchUp the contours are 1/4 the size they should be. I tried fooling with the units in AutoCAD to hopefully make them the right size, but nothing seems to work. Halp! I don’t know what I’m missing and I’m on a tight hours and dollars budget for this project.

Thanks much!

Truly,
a.

Did you check that the units in the Autocad file match the ones in the SketchUp?

Check the unit of measure

https://help.sketchup.com/en/sketchup/importing-and-exporting-cad-files

In SketchUp > Import… click on “Options” to set the “Units” match those of the dwg file.
2019-04-05_065604

Hi mihai.s,

Thanks much. Yes, I’ve tried making the AutoCAD file match the SketchUp units, and I’ve tried making the SketchUp match the AutoCAD units. Same result. The import comes in considerably smaller.

What I ended up doing was just taking a known dimension and scaling it up in SketchUp. Thanks again!

Truly,
a.

Can you post a DWG file that fails to import to the correct scale in SketchUp?

I have read that you have already tried to make sure that they have the same units, but I show you about “Options…” because I don’t know if you have seen that there are three elements that you need to keep in mind:

  1. autocad file units;
  2. sketchup file units (Window > Model Info > Units);
  3. and units at import (File > Import > Options > Scale Units).

Here’s the file. I know I’m missing something, but I can’t figure out what. As I mentioned in a previous post, I ended up just scaling the flatwork off a known dimension, but it would be great if I didn’t have to do that. Thanks for the help!

Alamo - Flatwork.dwg (68.3 KB)

Hi mihai,

Yes, I tried all those. From AutoCAD, from SketchUp, and units at import. It came in again today the same way. The length of the back property line is 76.5’, and it came in at 6’-something. I’m stumped.

I posted the file to this thread.

Truly,
a.

I imported the dwg file without making any special settings and these are the dimensions of the terrain:
im-5

I used pCon.planner to open the dwg file and then export it as a SKP file.
im-3

Alamo - Flatwork-pcon.skp (50.3 KB)

To me it seems that it imports correctly if I use Inches as the import unit:
image
image
Alamo - Flatwork.skp (190.3 KB)

Hi Anssi,

Yes, I have made that selection using the Options button and made sure it’s in inches, and it’s still coming in to SKP considerably smaller on my side. I’m not sure what the hang up is. I’ve made sure in AutoCAD that it’s Architectural Inches, that SKP is Architectural Inches, and that the Options>Scale is Inches, and it still imports tiny.

I’ve also tried “reversing” it, matching SketchUp Model Info to decimal feet to match the AutoCAD drawing Units, and setting the Options to match on import, but that doesn’t change the import size problem either.

For now my solution is to import and scale up the imported drawing, and I’ll just have to go with that.

Thanks for your help!

I’ve attached the topo that came from the civil. I’ve bound the XREF drawing, exploded everything I thought I needed to, purged unused, audited, and checked units.

Here is what I’m getting:

Again, I’ve left certain layers frozen that I didn’t need. I can explode absolutely everything if I must, but that’s tedious, and didn’t seem necessary given what I was following in Daniel Tal’s book. Maybe that isn’t the correct process anymore? I’m open to suggestions, because I suspect I’ll run into this problem again on import of another drawing like this down the road.

Thanks again.Alamo - Topo.dwg (480.9 KB)

Your topo has somehow been scaled.
I got the exactly same measurement when viewing the DWG in DWG TrueView.
image
The “Flattened” file seems to be right but this one is not

EDIT: the solution is simple: import the topo file using Feet as the import unit. The DWG has wrong units (inches) specified internally. It matches your flat file exactly when imported with Feet. Here the two superimposed.
Alamo.skp (452.6 KB)