Image upload error in 3D warehouse : 'File format is not allowed'

Using ‘Reverse Image Search’ I want to upload a simple image so the Warehouse can search for that in the library. I tried to upload the image in PNG and JPG. It’s 40 kB. THe viewer says that these are good formats for upload.

But whatever I try I cannot upload it and get this message ‘File format is not allowed’

Anyone any suggestions?

Share the image so we can see what you’re starting from.

This is what I got when I tried it with the image you uploaded.

Maybe the foru changed the format? You could try downloading the image from the forum and see if searching with that yields the same sort of results.

It doesn’t look like the Warehouse has the thing you are looking for. What is it?

When I try the to upload the image. I get the message ‘file format is not allowed’. Tried with different pictures and different formats. All the same error. 3D warehouse isn’t even searching for the picture, it directly gives the error.

So for my it’s not about the specific item but more that I get the error. And I don’t know what’s the reason is for it. I am logged in and have SketchUp pro.


I did the search in my browser, not in SketchUp. Now trying it in SketchUp and I get the same error message. Maybe @TheGuz or @Barry will have some info on this when they get back to work on Monday.

it could be a chrome-related issue, I tried in SU, same error, while on firefox, it’s all clear.

And then I remembered having issues with JPG a few years ago, solved by renaming them jpg

So I tried. PNG in capital letters is refused, but simply renaming it png works.
Capture d’écran 2023-08-05 à 22.04.23

You’ll find similar situation in various softwares, a quick search :

according to reddit, it’s an issue of case sensitivity.

1 Like

Yes. Small letters .png works. Thanks!

I was able to recreate the “image search using image files with uppercase file extensions inside of the SketchUp 3DWarehouse window (which uses the chromium embedded framework)” throws an error issue. We have added a ticket to fix this which will ignore the case and allow it to search without having to change the file extension to lowercase.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.