Image texture added by dropping down from desktop doesn't render in Vray

Hello there,
I have a problem with my Sketchup Vray. I added textures by dropping a jpg image from dekstop and spent hours positioning it properly [photo]. After starting render these textures don’t show up. However, a glass texture which is available in the materials menu does render [photo]. I noticed that the texture doesn’t appear in the materials tab. After adding a new material from the materials menu it renders properly, although I don’t want to spend a lot of time positioning the material again [photo]. Is it somehow possible to convert the image to a proper material in order to print it?




Did you explode the image after you dropped it into SKP, and then sample it with the paint bucket to assign it to faces?

Do you have material override enabled?

I think yes.

I added a jpg texture by dragging it from the desktop and dropping in Sketchup, having a particular group selected (eg. group with all exterior walls). I used pipette/dropper tool to select the image and painted the walls with paint bucket tool. Then I adjusted the texture using “texture → position” tool. I scaled and rotated the material properly.

You will need to check the material settings in Vray for it to show up properly.
Also make sure material override is switched off in the settings menu of the asset editor.

The texture needs to be added to the diffuse slot of the material for it to show properly in the interactive render of vray. Generally sketchup does this automatically (transfer to vray) when you add a material.

First thing I would try is to explode the image you brought in. Then quite SketchUp and restart. If it doesn’t show in the materials tab it likely will not render properly.

Exploding an image usually turns it into a material.

But, if you are using VRay for this you won’t really get a realistic render with just the SketchUp materials. You’ll likely want to build or find materials with proper normal / bump / displacement / etc. maps.

That’s why you can’t see the materials, you must disable it.

I haven’t tried it recently but SketchUp had a bug where if you placed an image inside a group or component you could then use it as a material. It wouldn’t show in the Materials window and it would behave like an image (show up in Monochrome mode, for instance).

I exploded the material, saved, quitted and reopened the model. The image didn’t appear in the materials tab in Sketchup. It is also not present in the materials tab in Vray. I’m sending you the model along with the image source files in the next reply. Please check it yourself if you can. Thanks for help.

I turned “override materials” option off. I exploded the face and reopened Sketchup. The problem in my opinion is that the material / texture / image doesn’t show up in the materials tab, neither in Sketchup nor in Vray. I could add the material manually and convert the walls faces to it but then I would need to reposition and rerotate every face again, which really took me hours and I really want to avoid it. I am sending you guys the model along with the source jpgs of textures (with google drive because the files are too big). Please check it yourself whether it is possible to convert the image to a material.
Thanks in advance, Julia

https://drive.google.com/drive/folders/1vZwMiMGlyYiN_s94Uphx6tSr-H9cUH68?usp=sharing

There are four of those “materials” in your model: the tile roof, the brick walls, the wood in the door and the stone foundation. The evidence is that the textured shows up even if you turn on Hidden Line or Shaded display mode. The reason is indeed the bug that allows an image to be used as a texture if it is within a group or component. My solution would be to re-import the images and before painting anything, exploding them, or importing them as textures in the first place, or creating new materials in the materials browser and adding the image to the “texture slot”.

Also, if you don’t want to spend the extra time repositioning the texture, follow step by step:
Make sure to first have a vray material that you can apply.
Then select the faces that need to material
In the vray asset editor, right-click the material name and choose “apply material to selected”

This method for applying a material will keep the position. As opposed to sketchup’s paint bucket which removes all positioning info.

If you want more options for positioning, take a look at the extension SketchUV