Ifc import not showing walls

Hi everyone
Not long started using Sketchup and aiming to use itas my full time architectural drawing package (after many years using Vectorworks)
Using Redstick as my site measuring package but when i try to import the Redstick ifc file, the walls are always missing (even though report says they are imported)
I’ve tried the same ifc file into Vectorworks and it comes in perfectly.

Is there something i’m missing???

I’ve attached a sample Redstick ifc exported file if you wish to test

RedstickIFCtest.zip (6.5 KB)

Thanks in advance


You shouldn’t double-post your question.
(@AlexB can combine these topics?)

Apologies Cotty - wasn’t sure which section was more relevant :slight_smile:

Many active users are reading through all new topics, so it isn’t as important as it seems in which category you ask your question (as long as it’s only one :wink: ).
I’ve imported your IFC, but I don’t see walls too. They are in the IFC file if you look at it with a text editor. Sorry, I don’t know a solution for this problem.

I also don’t get walls from your file. Since the IfcImporter is a compiled plugin developed by the Trimble team, it isn’t possible for us to tell how it works or why it failed for your file. Someone from Trimble will have to provide the answer.

the file does generate some errors

[Error] No operation defined for:
[Error] No operation defined for:
[Error] No operation defined for:
[Error] No operation defined for:
[Error] No operation defined for:
[Error] No operation defined for:

but you can bring the walls into SU, by converting them to dae first in mac Terminal with a downloadable script…

/Users/johns_iMac/Downloads/IfcConvert-0/IfcConvert  /Users/johns_iMac/Downloads/RedstickIFCtest.ifc /Users/johns_iMac/Downloads/RedstickIFCtest2.dae --include --entities IfcWall

that will import as a single component, but if you go straight in, triple click an individual wall and group it, you can then add the ifc stuff back in…
extracting and xml allows you to reassemble with all the same groupings, names, etc…

		<IfcProject id="1F6f4quOed$$hnyPwM9ibN" Name="Project Name" LongName="" Phase="Project Status">
			<IfcSite id="0a4lLeafNRUWxueEcKJbMa" Name="Site" CompositionType="ELEMENT">
				<IfcBuilding id="0TwDFzlXtFPeqPyerbFgD2" Name="Building" CompositionType="ELEMENT">
					<IfcBuildingStorey id="3kF4D9M32NdZvJp6cnA_XR" Name="Ground Floor" CompositionType="ELEMENT" Elevation="0">
						<IfcWindow id="37TPAlXNxzgrG4RHDVrV1u" Name="Window_1" OverallHeight="600" OverallWidth="1419.03"/>
						<IfcWindow id="1TDj9w9ON5dz9KgJz$4SbW" Name="Window_2" OverallHeight="600" OverallWidth="1419.03"/>
						<IfcWallStandardCase id="1_arE675OTacTT40BQZUfl" Name="Wall_1"/>
						<IfcDoor id="0OmDFwG0MxXuiY5Ni49gOj" Name="Door_1" OverallHeight="2000" OverallWidth="820"/>
						<IfcWallStandardCase id="08kc3hdpSKON9Vm1XDDP6n" Name="Wall_2"/>
						<IfcWallStandardCase id="0KTrwEEjN1u7s5CefDxpRg" Name="Wall_3"/>
						<IfcWindow id="0kbg6ICr0pfNHBpt6hpCx_" Name="Window_3" OverallHeight="1500" OverallWidth="1419.03"/>
						<IfcWallStandardCase id="3k4IwOx2sLqrBn7X8WARD8" Name="Wall_4"/>
						<IfcWindow id="0tr5L8$IDPop2rOUC9nRH0" Name="Window_4" OverallHeight="1500" OverallWidth="1419.03"/>
						<IfcWindow id="3qmgB5NQIcPPcEoDSIyP1S" Name="Window_5" OverallHeight="1500" OverallWidth="1419.03"/>
						<IfcDoor id="0bPzgK7ROLfb8w4y_3Dz_r" Name="Door_2" OverallHeight="2000" OverallWidth="820"/>
						<IfcWallStandardCase id="2kiHsXmkNClekWtA9Ngo9l" Name="Wall_5"/>
						<IfcWallStandardCase id="1Jci0tBO32mWsJ5C9uWamZ" Name="Wall_6"/>


Thanks for that john_drivenupthewall
I did another test file and converted it all to .dae format then imported that and it worked fine

Still a bit of a long winded way to import an ifc file though :frowning:

I have had good imports with other ifc files [from Revet] so I think it’s a Redstick to SU issue with the walls in that file,
The xml for a revet wall shows far more detail.
did you assign a material to the walls, that may make them appear…

I’m looking at writing an ifc plugin at the moment so I have a vested interest…

Guessed it was only a Restick to SU as the walls show up no problem when i import the file into Vectorworks
Definitely interested in your Ifc plug in if it means i can import directly from redstick :smile:

did you try their dxf export?

my plugin is more about assigning materials ‘after’ import, for rendering, but keeping the ifc data intact…


Yes, all the other export types work as expected but they are only 2D export options (PDF, DXF, jpeg etc) the only 3D option is the Ifc export.
As Redstick is great for doing a 3d building survey it would save a lot of drawing time in SU extracting heights & windows/doors

The Redstick ifc to dae conversion via IfcConvert seems to work with no problems for the time being

The IFC file you posted looked quite OK in Solibri Model Viewer but walls were missing in Tekla BimSight. I wonder if the SketchUp IFC importer is sharing code with Tekla (both are Trimble products). I have noticed this with other files too, there are ones that BimSight refuses to open and that Solibri shows without a hitch.


I am just going to throw this in here as it may be related.

I tried to import this .ifc file using the Open Asset Import Library and it spit out errors like this:

The string ",0.,1.))" cannot be converted into a value.

Here is one of the offending lines from the .ifc file:

#443= IFCDIRECTION((0.,0.,1.));

I did a search and replace for all these “decimals” without the decimal part, and added a 0 after the decimal point. So now the line looks like this:

#443= IFCDIRECTION((0.0,0.0,1.0));

After that, the assimp importer was able to parse the file.

@jim_foltz, did you write ruby for the search and replace…
could be useful for a ‘Redstick’ importer until they fix it their end…

No, I just used the search and replace tools of my text editor. (Am trying to build a tool to convert any appropriate assimp format to .skp file.)

John_drivenupthewall and others: Is there anything that we can do at Redstick to assist with this IFC matter?

welcome to the forum @Redstick, [using the @ symbol will ping individual members]

I’d suggest opening a thread in the Developers forum with some sample models and an outline of what can be done your end…

i.e. can the decimal issue found by @jim_foltz be addressed…