Identifying materials

Within my model, I’ve applied materials to all the surfaces objects (or groups, or components). If i select any surface, a tiny preview of the relevant material appears in the bottom left corner of the “Colours” palette. But it’s not actually named, and if i hover over it the material name does not appear.
This is often not a problem, but sometimes, if i have several colours very close to each other, or (for example) several wood materials that are quite similar, its not easy (or even possible) to tell which material was used.
I can see the names of the materials available in the palette, but not the name of the material used in the model. Is there a way of telling what material is in the model?

use the eydropper.

while using the paint bucket, press command to see the eyedropper appear.

now, if you click on an existing material in your model, two things happen :

  • the material will be selected for you to use with the bucket
  • the material will be selected in the material panel

Capture d’écran 2023-10-10 à 11.46.08
(granted, it’s a faint grey line, but it’s selected)

Unless i’m misunderstanding, that doesn’t happen for me. If i use the eyedropper to sample a material in my model, a tiny preview of that material does appear in the bottom left corner. But the upper part of the “colours” palette does not have a light grey band around any material. And if I’m in the wrong palette (eg wood instead of stone) it does not take me to the right palette…
(Maybe different on a Mac?)…

I’m on a mac. so is my screenshot. pressing command is the mac version of the tool, on a pc it’s… idk, ctrl or alt.

yeah, it won’t, you need to be in the “colours in model” palette. Then again, if you’re looking for a colour in your model… it’s the logical place to be :wink:

I see in your profile you’re using Sonoma, and before anything, there is a chance macOS changed something. I mean, SU is using mac os’s material panel, if mac os decides not to apply a grey band around it, you’re it :smiley:
The bottom part of the panel is mac OS’s. SU has no access to it, they can’t add a material name or anything. the small grid of swatches is actually useful to transfer materials from one software to another, as long as they both use the standard panel.

I did a few tests, for some reason, the first time it didn’t select the material, clicking in the white background of the palette fixed it, all the subsequent times it worked fine.

so first, make sure you’re in the colours of model, if needed click once in the white background of the palette, and the eyedropper-select thing should work fine.
unless Sonoma is acting up. Since SU23 is technically not supported by Sonoma, it could be mac os acting up

thankyou ateliernab,
its not Sonoma, its me (!)
and thanks for your help, it hadn’t occurred to me that it would only work if i was in “Colours in Model” …


1 Like