I think it's misaligned, but if it is I can't seem to figure out how to fix it

This is the same part that I had all the problems with yesterday, completely re-done, 99% of the way there:

Solid inspector says it’s good, but there appears to be something wrong with the trianglular brace on the LH side in this pic. It’s not connected to the rest of the model correctly:

If I delete either of those to lines I lose the whole bottom of the model. If I edit anything random holes in the model disappear or fill up (it could be one or more screw holes, it could be one or more of the triangular cutouts…) and solid inspector tells me that those 2 lines have 4 problems that it can’t fix. I’ve been trying to fix this for hours. I’ve deleted it multiple times, re-drawn it, deleted the whole bottom put it back with straight lines to make sure that it’s all co-planar with no luck.

Anyone have any idea what is going on/how to fix it? I think it’s misaligned (I think it’s slightly higher the the rest of the model, I saw it once zooming into the area but I can’t seem to do it again), but I don’t know why and how it happened and I can’t seem to figure out how to fix it.
A8_Braces_2.skp (1.7 MB)

I’d say that is where the problem lies. If that section needs to be seamless with the rest of the base of the the model, it deeds to be on the same plane.

You have a discrepancy with the base from this point.

If you fix this you should be good.

I think that piece is not 90º but I don’t know how to probe it.
However tests make me reach that conclusion.
Remember you can set Youtube videos at 2.00x speed if it’s bored

1 Like

@scooter, how did you find that discrepancy with the base?
I mean … did you reach that conclusion using zoom and paying attention how it looks?

Yes I just looked.

There are a few other misalignments in that corner. I can only assume as some are as little as 0.12mm. But I don’t know what the part is for so I may be wrong.
50

1 Like

Scooter, I saw something like that when I zoomed in once, but I couldn’t do it again to see what the misalignment actually is. When I try before the line becomes a shape I go through the object and don’t see it. It looks like you’ve done it more than once, any hints?

The part is supposed to be a 3d printed part/brace for a 3d printer (at 100x scale) so that part is supposed to be 100% aligned and 90*. I can’t figure out how it got misaligned and why I can’t re-draw it straight referencing it off the part so it fits exactly.

Any idea why it’s getting misaligned when I build it off the side of the existing part using it as a refrence/guide? How do I fix this?

spawn2k99- you just did what I’ve been trying to do for hours in just over 2 minutes. LOL, I don’t need to speed it up :wink: if I did it in 5min I would be happy. Actually there were a couple of things that I am going to try to reproduce in a few min (stuff that I thought I knew how to do but it looks like you’re having much better results doing exactly the same thing, we’ll see, I might have more questions for you in a few minutes).

To start with, how did you make the corner arcs that fast? I know that was “quick and dirty” and to no specific dimentions but I didn’t see you g and delete the leftover lines after making them and the second 2 arcs it looked like you clicked and they were just there. How did you do that? I originally made mine using the arc tool (center point and 2 points) and drawing guides to make the R exactly 200mm (2mm in my actual part, again it’s scaled 100x) and then deleted the extra lines and guides. I found that if I’m running around with an eraser and cleaning things up already that was more clicks than just using the circle tool and drawing a 200mm R circle. Whatever you’re doing is MUCH faster, it looks like somehow you’re automatically getting rid of the extra lines and just putting the same radius arc in all 3 corners by clicking on them.

Quick way:

Draw your first corner arc an arbitrary size, about right but don’t bother with guidelines. Make sure it shows as ‘Tangent’.

Select the arc, and go to Entity Info. Set the radius to what you want.

The arc tool remembers the size, so when you next double click near a corner, it draws another tangent arc the same size. Two more double clicks, and you’ve done all corners of a rectangle.

Works inside a triangle or any other arbitrary polygonal shape with straight sides.

1 Like

It’s just zooming in as far as possible without entering the internal of the mode.

This looks to be a mistake and your ‘corner section’ has inferenced on the upper part of the rebate. Push/pull the tiny rebate flush with the rest of the base, as I assume it should be. Delete unwanted lines and redraw the corner section again as John describes or Spawn shows.

How do you not end up inside? If I start zooming in (using the scroll wheel) I get something that looks like this:

If I zoom in one or 2 steps further in I’m inside the object. If I try zoom in with the cursor higher I end up in the object faster, lower I eventually zoom in behind the spot I want.

Scooter, I’m still trying to figure out the zoom thing, but:

I cut out the part and drew a separate box the right height and stuck it in there, cut the corner off and then made the cutout. John, it took like 4 tries but I finally figured out the radius thing and once I did I was thrilled, you don’t know how much time this would have saved me drawing this thing. Anyway, it at least looks fixed, I think it is:
image

The zoom issue I can’t answer. Thats as close as I can get without ending up inside but it is a pretty close zoom. that rebate is something like 0.1mm. Hate to say it but it could be the mouse you are using. Someone else may have a clearer answer to this.

I had a quick look at the earlier, broken, model.

The faces of that open triangle weren’t quite parallel to the bottom - it had somehow got drawn slightly off axis, I think.

I even tried extruding the bottom, and the triangle, and drawing a plane to intersect both. Using Intersect Faces with Model, and deleting the edges and faces below the plane, I still couldn’t get the holes in the bottom to ‘cut’ the face, even in a scaled up copy

Read about Clipping Plane - search this forum - for an explanation of why OpenGl based displays always have a near and far clipping plane, to make rendering possible at a fast pace, by ignoring things you can’t see at the same time.

1 Like

Ok, this is the second or 3rd time I’ve had clipping plane pointed out to me. Honestly I don’t understand, how in this case does knowing about this limitation help me see what I’m trying to see? I mean I have a reason why I don’t, I don’t know why I was able to zoom in once from one angle and not again and why Scooter apparently has no problem seeing it.

I’m actually a little more frustrated with this and scooter’s suggestion that this misalignment problem that I had could be the mouse I’m using because I’m starting to wonder if the issues that I’ve been running into are not something I’m necessarily doing that I could learn to fix but something that just happens and doesn’t happen consistently from user to user and machine to machine.

BTW, the part printed well (the bits of roughness you see are printing supports that I didn’t finish removing yet):

1 Like

It may make a difference whether you are in Parallel Projection (which makes the Clipping Plane issue worse) or in Perspective view (Camera menu options).

It also tries to explain why sometimes you just can’t zoom in as close as you want to.

I’m not sure about this last point, but I’ve seen some suggestions that the near clipping plane can be influenced by whether you are trying to view the whole model, or just a selection.

I’m glad you finally got the part to print and I hope it proves useful.

Bravo!

What exactly is this part for?

For very close zoom in, you have to switch the view to parallel.

Camera>Parallel Projection

Remember to switch back to Perspective when you zoom out.

I have found that misalignment is very easy to accidentally do when working with very small geometry. It can be frustrating.

Narrowing the FOV in Perspective mode enables you to zoom in close.
Parallel Projection mode is far more prone to clipping while orbiting the camera.

Look to the top menus…

• Camera > Perspective
• Camera > Field of View … Type … 2 … and press Enter

Use the same commands to return the FOV to the default FOV of 35
See the Scenes in this example of your model:
A8_Braces_3.skp (429.0 KB)


A model is built of Edges supporting Faces.
You need to be able to see the edges clearly to be able to model with precision.

Turn off the eye candy, Profiles, so you can see what you’re working with.
Dump the 3D Printing Template and all needless dross that comes with it…



Combine relentless application of Inference Locking with a clear view of the geometry and 99.9% of your modeling errors will cease.

Know Your Inferences — SketchUp Help

SketchUp Training Series: Inference Locking



Vastly Improved Inferencing in SketchUp 2016



SketchUp 2017: What’s new? … More amazing improvements to Inferencing!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.