I can't export map in OSM format

Hi;
Every time I trying to export an area of map, it exports it as .mxl so it not work on sketchUp. what’s the problem. Actually I saw a clip : https://www.youtube.com/watch?v=KKUGAZXU4dY and this clip is exactly what I want. All what he export of map are “OSM” files, but mine are “MXL” that not work as what he do.
please guide me how to resole this problem.
gratefully
martinmiciciday

Which of the three methods indicated in the video are you using?

First method;
I done everything he said, except exporting “OSM” of map. His exports are “OSM” mine are “xml”. Is there anywhere to choose extension or convert xml to osm?

What web browser are you using? Have you tried a different one? Default format should be .OSM. Are you exporting from the Export tab?

Also, what area are you trying to export? Post a screenshot of the Latitude/Longitude coordinates (shown above the ‘Manually select a different area’ link.

This is what I done:
At first I started with chrome:
(unfortunately because of limitation, I don’t have permission to send two pictures, so I only send you the mazila picture)
Which gave me .xlm.
I tried with mazila:


I tried to open with other program, but suddenly I faced with “Office XML Handler”.
I don’t know what is this, and I thought maybe there have to be a “osm” handler which I should install it. I don’t know.But all I tried, exported xml.!!!???

Ok, this is easy to fix. Instead of opening the file (with Office XML)…choose ‘Save File’ from the pop up. It should show up in your downloads folder a ‘Map.OSM’. Don’t try to open it with any other applications once it’s downloaded. No need for that.

Screen Shot 2019-12-30 at 2.05.57 PM

thanks sir for your helpful guide.
I realized out that, there is different between chrome and mozilla, and in mozilla the way that you said completely worked.
gratefully
martinmiciciday

1 Like