I can’t activate Sefaira test!


I already have a license for Sketchup Make 2017 and I want to try Sefaira for Sketch up Plug in particularly.
I installed the plugin. I open Sketchup and it works normally.
When I want to connect I receve this message :
Trial users - your trial may need to be activated. Do this by opening SketchUp.

When I go to my Trimble account Sketchup Make is activated.
So everything seems to be all right but… I can’t try sefaira !
How can I solve this problem ?


Hi @alex21_09,

While Sefaira will work on older versions of SketchUp you need to install and sign into SketchUp 2020 so that the trial gets activated. Until you sign into SketchUp 2020 on your machine the trial does not get started. Could you give that a go and see if you are able to login to Sefaira?

Hi, I tried doing it but as my university gave me license for sketch up make 2017 i can not get the 2020 version. They said sefaira must work on the 2017 version and the thing is it worked on all of my course mates`s laptops except of mine. Is there another thing I can do and what could be the reason for it?


You can download and install the SketchUp 2020 trial from here.

Once you install SketchUp, please sign in, that will then trigger the Sefaira entitlement for you. After which you can continue to use Sefaira in SketchUp 2020 until the trial expires or use it in a different version of SketchUp that you might have.