I am not able to install a Plugin

#1

Hi everyone, I am trying to install a plugin (1001bit tools) in SU 2016 but whenever I try to install, it shows an error like “1001bit setup error–cannot find c:/1001bit_freeware/1001bit_loader.rb file”

How can I solve this problem?

Important Note: I am using Win10 and it is installed to “C:/” directory but I installed Sketchup 2016 in “D:/” directory because I don’t have enough free space in “C:/”

#2

Most likely the answer to your questions is in your last sentence.

#3

Thanks for asnwering, I know this can be the problem. Actually that is the point of me that asking this question to community. I tried some solutins that is offered in another topics but none of them helped me. If there is a way to show the right directory to this plugin I will be able to use it.

#4

Where did you install it from? Typically extensions are installed in the appdata folder, which is in your user folder, and SketchUp’s location doesn’t matter.

#5

I downloaded it from 3dwarehouse web site and installed it by watching these steps; SU>Window>Preferences>Extensions>Install

Plugin’s files are in the AppData folder but it is not working.

#6

It is possible that the extension’s registration file constructs the path to its loader file in an unusual way. Usually the path would be relative to the Plugins directory (better even relative to the registration file).

You have already found your Plugins folder. There should be a subdirectory “1001bit_freeware” and next to it its registration file “1001bit_freeware.rb” (same name). When you open it in a text editor, look for the line where it points to “1001bit_freeware/1001bit_loader.rb”.

#7

I looked into it, and despite of some oddities it loads for me.

It does indeed hard-code the file path to “c:/1001bit_freeware/1001bit_loader.rb” hoping for better weather or whatever, if it could not find the loader at the default path.
So I assume the default path cannot be found due to special characters for example. Do you have special characters in your computer account name?

If you edit the registration file “1001bit_freeware.rb” in a plain text editor, you could try to insert the following in the empty line after require 'extensions.rb':

@GH1001bit_path = '1001bit_freeware'

Then save the file and restart SketchUp. What happens?

#8

Ok guys, thank you all for your contributions. I solved it. I put the “1001bit_freeware” folder and 1001bit_freeware.rb file (which is in the AppData folder) to “C:/” directly and reopened the SketchUp than installed 1001bit again so that it worked.

#9

Even if it works, it should not be there. Having files or programs in the root directory is against convention and creates growing disorder. You should maybe contact 1001bit and report the problem so that they can fix it.

1 Like
#10

I will, thanks