How to split in half and pull apart model? anyone know how? thankyou

I am trying to split this object in half the short way and pull it apart so I can 3d print each side separately however all the online videos only show how to do it with a clipping plane and then deleting the other side.
is there a way to slice it where I can move the sides easily apart?
test2.skp (3.2 MB)

You cannot print it as it is not a solid.

Your model is all loose geometry. You need to learn how to use Components - separately for each building, for example, and for the terrain. Only solid components will print in most slicers. The model needs further work before you can split it into two printable parts.

None of your scenes have apparently been saved - clicking on a scene tab does nothing to change the view the way they are named.

You have tagged faces and edges - for example, building faces. You should only tag groups and components, and non-geometric objects like dimensions and text.

Most of the building faces are reversed, showing blue outside instead of buff.

The top right corner of the terrain is incompletely closed, and distorted:

Spend some time on the learn.sketchup.com site to get a better grasp of the basics of Sketchup.

1 Like

to 3d print it does not have to be solid nor do you want it to be solid because then instead of inprint it will print the whole thing solid causing it to take 3 times as long.

I think this shows a misunderstanding of what ‘solid’ means in SketchUp. Sketchup is a surface modeller.

A SketchUp solid has exactly two faces adjoining each edge. Think of it as a watertight membrane, with (normally white but buff in this style) faces outside, and blue (reverse faces) inside.

That way, the slicer for 3D printing will know what is inside, and what outside, each face. You may then choose (in the slicer, not in SketchUp) whether to print the inside solid, or as infill of only a percentage of solid printing - typically as little as 20%.

2 Likes
2 Likes

awww ok that makes sense thank you! I usually use Rhino but this model of my site I downloaded was on sketch up.I thought it would be a good model but guess not and its the only one I can find. do you have any suggestions on how to fix it? Like I said I’m not used to sketch up usually rhino but i need this for Monday.

I do have some suggestions but not tonight - it’s 12:45am in England and I’m about to head for bed. More tomorrow evening.

1 Like

Just starting to look again at your model.

When I open in in SU 2022, I get string of errors which the program says it has found and fixed.

Results of Validity Check.

CVertex (284232) references CEdge (284231) more than once - fixed
The start and end vertices are identical for CEdge (284231)
Entity CEdge (284231) should be erased - done
Entity CCurve (284237) is missing a persistent id - fixed
CVertex (284244) references CEdge (284243) more than once - fixed
The start and end vertices are identical for CEdge (284243)
Entity CEdge (284243) should be erased - done
The start and end vertices are identical for CEdge (284246)
Entity CEdge (284246) should be erased - done
The start and end vertices are identical for CEdge (284258)
Entity CEdge (284258) should be erased - done
The start and end vertices are identical for CEdge (284284)
Entity CEdge (284284) should be erased - done
The start and end vertices are identical for CEdge (284312)
Entity CEdge (284312) should be erased - done
The plane equation for CFace (193328) is not valid - fixed
The plane equation for CFace (193681) is not valid - fixed
The plane equation for CFace (194874) is not valid - fixed
The plane equation for CFace (194914) is not valid - fixed
The plane equation for CFace (196282) is not valid - fixed
The plane equation for CFace (199948) is not valid - fixed
The plane equation for CFace (200103) is not valid - fixed
The plane equation for CFace (200128) is not valid - fixed
The plane equation for CFace (200134) is not valid - fixed
The plane equation for CFace (200409) is not valid - fixed
The plane equation for CFace (202919) is not valid - fixed

Entity CFace (202919) should be erased - done

When I open Scene Manager in the Top scene, I can see you have no scene properties checked to be
saved.

.
Check all of them
Go to the menu Camera, Standard Views/Top
image
to set the scene to Top view.
Then select Zoom Extents from the Large Tool set toolbar (tool palette on Mac), or press Shift + Z together to achieve the same action.

R-click on the Top scene tab and choose Update.

Do the same for the other scenes, except set the view from the direction you want, instead of Top.

Since all your geometry is one connected set of lines and faces, it’s extremely difficult to separate the terrain surface and the buildings.

Is there any way you can re-import them separately?

I’ve tried selecting the buildings in two different ways and failed. Setting up a scene for Front view, Camera/Parallel projection, I tried to crossing select (right to left) round either all the buildings just above the top of the terrain, or just a group of them, and making them into a component. It didn’t work well. Nor did a Top view.

I see no real alternative to working through the top faces of the buildings one at a time, adding each to a selection. Perhaps work through the separate areas between the roads one area at a time.

Most if not quite all of the roofs show blue (reversed, or upside down faces that should be white and facing up). With all the selected roofs showing selected, R-click and Reverse faces to turn them white.

Make the combined selection into a component, and create a new Tag Roofs and assign it to this component, then hide the tag.

Doing this for the top left group of roofs left a mixed picture, with some of the buildings showing ‘Z-fighting’ - partially white floors.

This shows that parts of some of the building floors have two faces in the same plane. Probably parts of the floors are just above or in the same plane as the terrain in the same plan position.

Delete just the white parts, to leave just the terrain surface. - see for example this building top left in Top view. You have to select each little white area one at a time then delete it.

image

That should leave you a continuous terrain surface (in this part of the terrain), which you can highlight with a single click anywhere within it. When I first thought I’d finished this, I later spotted a few remaining white areas. Delete them too, to get this:


Make this surface into a component (named for example Terrain 1) with its origin at some fixed point for all this and later terrain fragments. Create a new Tag Terrain, and assign it to this component.

Window select round the remains of the building walls and make them into a component (Walls 1 for example), and tag them with a new tag Walls. Turn off that tag as well as the Roofs tag.

That leaves a lot of short visible lines. Soften them into the terrain to make them invisible.


Repeat the process for all remaining groups of buildings. I haven’t time or inclination to do them all.

But this process appears to have separated building walls, roofs, and terrain for one area. I hope doing the rest will do the same for them.

You than have to fix the badly drawn upper face of the terrain block, and reconnect it to the terrain surface. That’s a mess, and also hard to resolve.

The whole model needs far too much work (in my view) to make it a clean SU model, let alone divisible into two and 3D printable.

In principle, you should be able to draw a new face parallel to the top terrain vertical face and a little way inside it but not encroaching on the buildings, intersect faces with model, and create a new clean face there by deleting left over faces and edges. I tried, but didn’t have much success.

The best i could manage was a top face of the terrain with multiple soften lines making it look like a face, but it is multiple faces.

Here’s the partially corrected model, to SU version 2017 so more other people can have a go, and you can open it yourself in SU 2020 which your profile says you are using. .
test2 JWM.skp (4.3 MB)

I’m sorry, but I think (as the Irishman said to a tourist who asked the way from where they were to Ballysloughguttery) “If I were you, I wouldn’t start from here”.

Go back to the original source from which you received the import, and clean up the model there first.

I have had another simpler thought about separating buildings and terrain.

First, remove all the tags from the model. (Select each tag in turn from the model, R click and choose Delete tag. In the popup dialogue, select Assign another tag: and choose Untagged.) They have been wrongly assigned to faces and/or edges, and are confusing things badly. The Default tag isn’t empty, but toggling it on and off makes no visible difference to the model.

Then reset the scenes as I described above.

Select the top surface of (most) of the terrain, make it into a component, assign the tag Terrain, and turn it off.

Then select the bottom face of the block of terrain, make that into a component, assign the tag Terrain, and it too will be made invisible.

That itself should be a flat face, but it has a dividing line near the top, which when deleted loses both parts of the ‘face’, so select both the parts, and make that into a component instead of just a part of it.

Now you are relatively clear to window select round the buildings, area by area, create and name a component for each, and set the Component Axes at the bottom left corner of the model. Tag each component as Buildings, and then turn them off too.

At the left edges where buildings overlap the terrain, you may lose some of the terrain block edges. Reinstate them.

Then try to rebuild the terrain, by reuniting the parts left in the model, and making the top and bottom visible and exploding them.

Good luck.