How to show SU model with dashed Lines in Lay Out?


So, i am looking for the “best” way to show “hidden” lines in LayOut as dashed:

Lines below ground shown as dashed.
This was done by exploding the viewport, selecting lines, setting to dashed.
But that was cumbersome, as some lines were extending from below- to above- ground, so they needed to be redrawn as 2 separate.
So, i guess that’s a common problem with a number of ways to address?

What i tried out and/or was searching for:

I was hoping for a dashed line-style in SU, and then stack a viewoprt with that above one with solid lines…
But it seems there’s no way for that.

I think the dashed-line plugin in SU won’t help, because i also need to show the bleow-earth stuff as solid lines in other LayOut pages.

I tried Style Builder quickly, but that’s only for Sketchy line-styles… Trying to create a dashed style, i found out these styles are always scaled to fit, so this will never lead to a CAD(-ish) look.
But here it seemed to me just this was achieved:

Tried to use the hidden-line option in styles, with a temporaty surface between camera and object, but this shows also hidden lines inside the building, i guess to only get the lines of the face i would need to combine it with a section-cut, or actually multiple ones, as the building face is not all on one plane… not practical i think.

I have read

But that is more about lines that ARE dashed, and not about a way to SHOW all lines AS dashed…

Allow to apply line-styles to SU models

There is no provision for dashed lines in SketchUp. The lines in SketchUp are really edges to define the boundaries of faces. The Dashed Line plugin divides edges into short segments and then hides every other segment.

I think you’ve hit on essentially two options. You can make a scene that shows only the edges you want to see, stack its viewport (put it on a different layer than the other viewport) and explode it. Then change the line style in Shape Styles.

I need to show hidden lines quite frequently and the method I use works well. I set the style for the scenes with Back Edges turned on. In LO, I leave the viewport in Raster until I trace the needed edges with the Line tool set to the dashed style I want. Then I render the viewport as Vector and the back edges are no longer shown. If I need to make edits in the model that affect those dashed lines, i just re-render as Raster, fix the lines and render back to Vector.

You could also update the style in SketchUp to eliminate the Back Edges and then update the reference in LO.


Here’s yet another dumb LayOut workaround:
I made a dense grid of white thick lines and put that as a “filter” over a SketchUp viewport (wireframe or hidden lines). It might work best with rectangular things

Another, even easier: Use a semitransparent pattern as a filter. This one with “White dots 4”:



how about taking a section cut of the view required, cut a slice or a 2D view then export to a economical or free dwg file program like Draft sight, change the line type, amend then print and import into layout as .jpg or .png, (paper size match, scale and position helps)


That’s an interesting idea, Philip. I guess if I were going to make the dashed lines using edges from the model, I’d probably make a scene/viewport, render in Vector and explode so the lines wouldn’t be raster image. It would be easier to get the size and scale correct and if needed, it would be easier to replace the dashed lines if the model gets changed.


Thanks all.
So that’s a nice number of workarounds.
Has anyone ever heard a statement from Trimble (Here, Discussions at 3D Bascecamp, …) how they see that problem-area?

I guess that, as DaveR stated, it is quite a common task, and all the tips here feel still much more like workarounds and not like official recommended best practices…