How to separate walls from floors in 2d sketch (top view) in order to raise walls separate from floors


#1

Forgive me if I’ve missed this topic in the forum, but I’m designing a house floor plan in 2d/from the top view and now I’m ready to raise the walls to height in order to build a 3d sketch, but when I select the wall area (between my stud lines), some of the floors within the walls will also be selected. I’ve looked around all the walls to make sure all the walls are “complete” and not open to the floor space and I’ve traced along all the walls again to close in any spots I didn’t see, but I still can’t figure out where the floor area is bleeding into the wall area. Is there a certain style view that will help me spot what’s going on? Thanks for any tips. I tried attaching the file to this post, but it said it was too big, so I’m going to see if I can upload it to my profile after I post this.


#2

A floorplan shouldn’t be too big for the forum.
Go Window/Model info/Statistics and hit the Purge Unused button, then save and try again.


#3

dygert house '18 final test.skp (875.8 KB)

Thanks, Box. Just did what you said. I also uploaded the file to my profile publicly just before I saw your message, but I’m not sure how to share that specific to this thread.


#4

Looks to me like you may have gaps in your lines preventing areas from “closing”. I notice that everything is on Layer 0 and you don’t seem to have any components or groups. Lines, surfaces, text, dimensions, are all jumbled in together. You can work like that but you will soon run into difficulty.

When I do this kind of thing (which is a lot), I start with the walls and make sure they all join up and create a surface between their real-world faces. You may have to keep deleting surfaces created that might usually represent the floor. Once you have the walls right, make them a group or component. When you re-open the group, you will be able to extrude the walls to the height you want. If you want to show a floor, make that a separate group (could be just a simple slab of given depth).

You can do the same with the next floor but instead of having it displaced horizontally as you have it, move it on top of your ground floor walls. That makes it easier to see that walls run through from floor to floor where they are meant to.

I would create layers to represent different elements. At the very least, you would have Floors, Walls, and Annotations (text/dimensions), but you could break it down further into floors, say. Then use scenes to show relevant views (ground floor plan, first floor plan, etc). Floor plans can either be done with top views of your group in parallel view, or by creating horizontal sections.

One other way of dealing with the closing issue is to start with a rectangle bigger than you need and then to draw your lines on that, making sure that ends meet up. This sill ensure that all lanes are planar. Lines sometimes look as if they meet but don’t quite because they are in fact off plane.


#5

Thank you for all the info. I can try deleting floors and reconnecting walls and then make into a group. Unfortunately, I’m so new to this that I didn’t even know you could make different layers (or I just don’t understand what they are). I’ll start with what you first suggested and see how that goes.


#6

Some information on Layers for your review, there’s a video at the bottom of the article that is useful too. https://help.sketchup.com/en/article/3000122


#7

Here’s a quick vid to show you how quickly and easily you can do what I describe.


#8

Hello Simon, thank you for this video tutorial this has greatly helped me at this time. Please may i ask two questions which i am stuck with today.

  1. I would like to use a 01 pixel for drawing very fine lines especially small bits of geometry but the moment i set this up my Template disappears? anything i should know as to why this happens please?
  2. I have never used the “Lock” for anything but it says “Locked” and i am unable to “Unlock” no matter what i try or do? is their anywhere else to unlock whatever is “Locked”? I would be most grateful for your kind assistance herewith. Many thanks once again. Best regards Lynda

#9

Hi again Simon, would you care to upload this video to Youtube and post the link on this forum? i would like to keep this as reference. Thank you. Lynda


#10

Where are you setting this up? A screen shot would help.

Again, I am not sure where this is occurring.

I’m afraid I don’t keep things like that. I suggest you reproduce the steps I took and create your own video using (say) Licecap.

It would help us if you completed your profile and include which version of Sketchup you are using.


#11

Right click on the gif and select Save link as and choose were to save it.


#12

Thanks Box, much simpler!


#13

Hi Simon, thank you for responding.

The Pixel is in Windows - Styles

The Hide or Hide and Lock or Unlock is under Edit

Thank you for all, much appreciate your help.
Lynda


#14

The line size in Styles applies to all the lines in a model (specific line weights cannot be applied to only certain details).


#15

OK. I don’t know why that might affect your template. Changing Profiles under the Styles tab does reduce the apparent width of lines on screen.

So you can lock a group or component to prevent it from being edited, but as this shows, if you right click you normally get the option to Unlock (4th item down).


#16

Hello Simon and TheOnlyAaron for both your responses, much appreciated.

Aaron I was setting up a New Template and wanted to use a finer line weight for all my drawings and chose to use 01 pixel but as mentioned the template disappears and i have a blank screen and even the guy standing near the origin turns to a sketchy subject?

In response to Simon, thank you again i will try right clicking to unlock and see what happens this time.

Thank you both for your assistance once again, take care Lynda


#17

Nice demo.

BTW, as a shortcut to creating a new layer in the layer palette, and then going to the entity info palette to assign the group to it, you can create a new one right there in the entity info palette; if the layer you want doesn’t exist, just type the name of a new one.


#18

Yes, indeed. I actually don’t like that feature even though it can save time. What often happens in practice is that you inadvertently create a layer you didn’t want. Mine always seems to be Layer “m”.


#19

I may be wrong, but I think that only works on a Mac?

That is due to an oft criticized aspect of the Mac SketchUp GUI: it leaves many text fields active after you type an entry until you click somewhere else (even if you press return). I most often get a space, as I reflexively hit the space bar to activate the select tool.


#20

True enough.